gpg: no valid OpenPGP data found. - when updating

when im updating syncthing im getting this error. i read this post of how to add key. but i cant find any syncthing key hash. someone face this before?

Please refer to these instructions:

1 Like

I still have the same error. There is any other way to save the key?

How did you install Syncthing?

Did you install it with Ubuntu (for example, with apt-get), or did you download it from

Please post the exact commands you ran, and the exact output you say.

some how i managed to install it from this guide.

here is the prompts. when i sudo apt-get update.

Hit trusty/multiverse Translation-en
Hit trusty/restricted Translation-en
Hit trusty/universe Translation-en
Ign trusty/main Translation-en_US
Ign trusty/multiverse Translation-en_US
Ign trusty/restricted Translation-en_US
Ign trusty/universe Translation-en_US
Fetched 2,917 kB in 24s (119 kB/s)
Reading package lists... Done
W: GPG error: syncthing InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2B9FAE4C37C86D31

when i trying to add the key as the guide says.

orangepi@OrangePI:~$ curl -s | sudo apt-key add -
gpg: no valid OpenPGP data found.


What is the output of curl -s on its own?

i think i managed to solve it. i tried the following

gpg --keyserver --recv-keys 2B9FAE4C37C86D31 (this is what the error message show)

gpg --export --armor 2B9FAE4C37C86D31|sudo apt-key add -

then when im doing update syncthing version change only when im doing reinstall like sudo apt-get install syncthing

is it should be like that?.

Can you answer canton7’s question about the output of the curl command? That should work, and something isn’t right if it doesn’t work.

orangepi@OrangePI:~$ curl  -s

I think your curl is broken somehow…

Indeed, that command should print a PGP public key to stdout.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.