GPG error when setting up syncthing in Debian 12

New to syncthing and followed the documentation to setup for Debian but when I run apt-get update to pull the repository I get a GPG error saying the signature couldn’t be verified. Wondering if anyone knows whats up? I attached the error output to the thread thanks to anyone who gives this a look.

It looks like the public key wasn’t installed.

Maybe caused by this?

Note the necessary -L option to curl so it correctly downloads the key file.

I tried adding the -L flag to the end of the command and I still get the same error output. Is there anything I need to do to refresh to make this work?

Instead of cURL, try wget:

wget -O /usr/share/keyrings/syncthing-archive-keyring.gpg

Or, paste into a web browser to download the GnuPG key. Then move the file to /usr/share/keyrings/syncthing-archive-keyring.gpg on your Debian machine.

Worked! Thanks so much for your help. Any ideas what was going on with cURL?

None, as you didn’t show any output from that. :wink:

Our instructions currently reference /etc/apt/keyrings/ instead of /usr/share/keyrings/. Maybe you mixed something up there and the APT sources file was pointing at the wrong location?

I just tried the instructions on again and they worked fine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.