Global discovery not working

I used syncthing to synchronize a folder on 4 different windows servers and it worked beautifully

I then shut down and deleted the original folder master, and now want to set up duplication from between two of the original servers, but I cannot get them to discover each other. I even tried deleting the folder containing the db file (C:\Users\Administrator\AppData\Local\Syncthing) and restarting setup, but still nothing. Both servers are on AWS EC2 (source windows 2003, target windows 2012) I don’t think it can be a port thing as they both used to work Any clues?

PS: When I entered the ID of the opposite server neither of the servers requested to restart as they normally do when a new device is added Its as if they both know of their previous involvement with each other in the original sync group

Did you try to reuse the old ID?

If so, did you reuse the key.pem and cert.pem file from the old config dir? Without them, you need to use a new ID.

Adding devices no longer requires restart. No idea on the actual problem, apart from what @wweich hints to.

How get list of connected device on discovery server ?

Initially I guess I did, but when it didn’t work, I deleted the folder containing the db file (Windows folder C:\Users\Administrator\AppData\Local\Syncthing) on both servers, and the software recreated it (I assume with a new ID) the first time I ran it.

Yep. The device ID essentially lives in the two files cert.pem and key.pem in that directory.

So deleting the folder should do the trick How do I enable some sort of debug logging to find out where its stalling?

Deleting the folder does absolutely nothing to help with discovery, it just ensures that your old device ID is gone and invalid - and thus will never be successfully discovered by another device.

To get some debugging on what’s happening, run syncthing from the console after setting the environment variable STTRACE=discover.

Thanks I did that and both end logs show this line:

discover udp4:// Lookup(other machines ID) result: [other machines correct IP address:22000]

Could it be a firewall issue? Do I need to open port 22000?


TCP or UDP? How come I didnt have to do this on the initial setup?

If you have UPnP enabled on the router, it should ask the router to map the port for you. Alternatively, the other side might already have port forwarding available which should be sufficient, or the other side managed to get it setup via UPnP.

Basically, one of the sides has to be available on the internet, via TCP.

These are both Amazon EC2 servers - one Win2k3 and one Win2012 The 2003 has fw turned off I’ll have to try opening port 22000 on the 2012 server in the AWS console

That was it once I let TCP port 22000 thru both the Windows 2012 Firewall and the Amazon EC2 firewall it started syncing

Still don’t know why I didn’t have to do that the first time around

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.