Global discovery disabled on both sides still able to connect


Recently I was changing some stuff in my cluster (remote devices, not in the same LAN) in such a way that I had to edit my remote devices adresses in order to keep everyone able to connect to everyone (I don’t want to use Global Discovery). But just as I was about to make the changes, I noticed that two devices were connected, even though they weren’t supposed to. So just to be sure, I restarted Syncthing on both devices… and they still were able to connect. So I made sure that Global Discovery was disabled on both sides, set both of their remote adresses to dynamic and restarted once again… and they still were able to connect !

Am I missing something here ? How is this even possible ? Strangely, while the ports are forwarded on both sides, it is always the same that acts as the client, no matter what order I restart the devices (to trigger the connection from a specific device).


I don’t know, but you can figure out. Since the connection is made client->server, look at the side that considers itself the client. Pause the device. Look at and hover over the addresses to see their origin. Screenshot.

There is caching of discovery results, but not across restarts…

Well I don’t get it : between the time I posted and now, I had configured the remote adresses (just to be sure that they stay connected) and right now I removed them to follow your instructions and I didn’t even have to restart (just pause-unpause) : they now can’t connect.

So everything seems fine, but there might have been a small glitch with the discovery caching (fixed by changing the settings once more saving), don’t you think ?

Anyway, thanks for your help and for this amazing piece of software in general : this is one of the best tools I’m using on a daily routine !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.