Global discovery 0/1 on nas


I tried to configure sync between three devices: synology, win7 and android. Win7 and android shows global discovery ok (1/2), but nas always shows (0/1). Syning between three worked (because of local discovery, I suppose). Both win7 and nas are configured with upnp support, both are showed on router, everything looks fine from that point.

No errors in log on nas:

[4A4MP] 19:08:12 INFO: New UPnP port mapping: external port 7097 to local port 22000.

[4A4MP] 19:25:31 INFO: Established secure connection to at <NAS_LAN_IP>:22000-<ANDDOID_LAN_IP>:50816

Where should I dig from? Why global discovery if offline? I think that it is working only because of local discovery. It would be dissapointing to fail syncing from other network through internet.

The (0/1) on the NAS means it only tries one server, which is odd.

Your Win7 tries both, the IPv4 and IPv6 and probably only succeeds with the IPv4 one.

Check your Settings on the NAS Syncthing. It should have udp4://, udp6://


I checked it, config has only udp4 and port in configuration was 22025 instead of 22026. (strange)

After adding two servers you provided nas started to show connection (1/2)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.