Ghost changes

With the new function that shows the unsyncked files at remote servers I found unsynched files with these descriptions: (folder and filename replaced “…path…file…”)

  • |…path…file…JPG|0 B|2014-08-05 18:19:18|Unknown|
  • |…path…file…JPG|0 B|2015-10-16 13:49:26|Unknown|
  • |…path…file…jpg|0 B|2010-08-06 18:47:28|Unknown|
  • |…path…file…JPG|0 B|2013-04-05 10:58:49|Unknown|
  • |…path…file…JPG|0 B|2012-02-22 10:07:24|Unknown|
  • |…path…file…JPG|0 B|2015-07-06 11:20:06|Unknown|
  • |…path…file…doc|0 B|2012-08-02 13:31:57|Unknown|
  • |…path…file…JPG|0 B|2012-10-28 10:04:02|Unknown|
  • |…path…file…JPG|0 B|2012-07-20 06:05:55|Unknown|
  • |…path…file…doc|0 B|2010-04-29 19:14:20|Unknown|

I tryed to find the file to check if there is another capital leter problem, but the folder path doesn’t exist.

Also, with a very old date, when I installed syncthing on 2017-08-15.

All my server are not fully synked showing 99%.

To recap: Folders on all involved devices show up-to-date but all involved devices show these files as not synced for the remote devices.
In similar past cases, the delta indexes were out-of-sync. You can check by getting the file information for an affected file via the rest api:

Thanks for your reply. I understand that with this API command I can do a query to the synchting and check that its detecting the problem. But I don’t know how to run this command. And I don’t know how it will help me to solve the problem. I must apologise if I am not able to understand the workaround.

Ah sorry, I was just being lazy and not explaining what to do in detail. Most likely running syncthing once with the -reset-deltas option will fix your problem, so lets try that first. If you share a lot of data and/or your connections are slow, it might take a little time until everything shows as up-to-date again (and hopefully those “ghosts” go away.

I am restarting server one by one, for the first 3rd machines was usual time spend for rescan and resync. but when I turned on a 4th server, take so long, hung up, slowing shared folders, and unreliable. the 4 servers are on, when the 4th server where synked with one of the other machines apeared again that there are the 10 ghost files. What I am doing incorrectly ? Only one current server each time ?? Stoped and isolated all servers to resync files and before connect with other servers ??

why I have this line???

[LRXWV] 19:28:57 INFO: kcp:// resolved external address kcp://46.18 .47.150:22020 (via

the server is using an external ip for something ?? can i dissable the kcp ??

which is the purpose for these options ?

Kcp Congestion Control

Kcp Fast Resend

Kcp No Delay

Kcp Receive Window Size 128

Kcp Send Window Size 128

Kcp Update Interval (milliseconds) 25

Please search the forum, this was answered before.

3 weeks later, it seems that all was correct… this morning all servers shown again files to be sync from unknown devices!!

I need to -reset-deltas again in all servers ? It was an awful experience, I should do the reset one server at a time ? or I need to do at all together ?

I can’t understand why is detecting changes more than 5 years ago 24.1 KiB 2010-11-12 19:21:06 Unknown

You probably need to shut all of them down one no known files are out of sync, do a -reset-database on all of them, and start them back up. Potentially set one of them as master before hand. It seems that some device has announced some files a while ago, and those files are no longer to be found anywhere.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.