Getting a better (non-relay) connection?


I have been using Syncthing for several years now and love it. Now that the connection icons are shown next to remote devices, I realize that my work laptop always connects with a relay. Is there any way to somehow force this to be a TCP LAN connection when I am working from home?

My assumption is that because this is a work PC, it is on a different domain (my work domain) than the rest of my network (“workgroup”).

Is there a way to do this, or is this just something I have to live with?


1 Like

There can be many different factors at play here, but just a quick question, what operating systems do the two computers run?

The work laptop is Windows 10 Pro/Enterprise(?). All other PCs are either Windows 11 or Mac OSX. Syncthing is running on my NAS (TrueNAS SCALE). I used to run Syncthing on a SFF PC running Linux Budgie, but I recently migrated it to my new NAS.

I don’t know if the connection from the work laptop to the old Syncthing was getting a relay connection or not.

When it comes to Windows, please just make sure that your home and work networks are set to private and not public (see or otherwise Windows won’t allow direct connections no matter what. Also, you’re not going to get a “TCP LAN connection” when not on the same network, but you should still be aiming at either “TCP WAN” or “QUIC”, of course.

OK thanks. I will look into that. There are various security restrictions on the work laptop, so I may not be able to change some things, but I will check.

Just for grins, I tried connecting that work laptop to my old syncthing install on the linux machine (without setting up any shared folders), and that one connected with TCP LAN, so I am not sure why the NAS install doesn’t connect the same.

Is your work laptop using a VPN connection? Some IT departments set the VPN connection as the default gateway which causes all traffic to be routed via the VPN interface.

I was able to change the network connection to Private (it was indeed public). I rebooted but Syncthing still connects via Relay.

We use a VPN on them, but only when necessary. The VPN connection was not active on the recent tests.

My next best guess would be the firewall.

ANy idea how to chase that one down? The confusing part to me is that the linux machine running syncthing on my network works fine and allows the TCP LAN connection to this work laptop, but the NAS version does not. Could it be the fact that the Syncthing instance is running in some sort of container on the NAS?

Possibly, but we’d need a lot more details, including screenshots of Syncthing’s web GUI with the relevant panels expanded so that the details are visible – it’s quite difficult to diagnose network issues without any details about the network in question. :wink:

If you’re running Syncthing as a docker container i would recommend to use host network mode.

In the case of Windows, you could simply try to (temporarily) disable the firewall completely and see whether there is any improvement.

I will dig into this a bit more later. Syncthing is a plugin for my TrueNAS SCALE installation, so I need to figure out if this can be configured…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.