FS watcher


(Andrew Chung) #1

Hi,

While trying to get Syncthing setup to sync between two Linux computers, I ran into this error on one of them: |Default Folder|error while traversing <actual path redacted>: function not implemented|

If I manually force a scan through the web interface, it is able to pick up the changes and push to the other computer.

I have tried searching online for this error but have not found any hints on what may be wrong. Any suggestions?

Thanks Andrew


(Simon) #2

Are you running some exotic system (os or architecture)? First guess would be that inotify isn’t available on it.


(Andrew Chung) #3

This is an admittedly old system (still running Debian lenny with 2.6.26 kernel), but otherwise nothing special. I have confirmed with inotifywatch that the inotify facilities work.


(Simon) #4

Then it’s probably that the inotify API changed since then and golang.org/x/sys/unix (i.e. the commands used on it) isn’t compatible anymore. I unfortunately don’t have the time to investigate for such an old system. You can disable change watching in the folder editor in the advanced tab, meaning you will rely on regular full scans.


(Andrew Chung) #5

Ah! Found it. Syncthing uses inotify_init1(), which was introduced in Linux 2.6.27… Do you happen to know if it is generally safe to revert to inotify_init() without the CLOEXEC flag?


(Simon) #6

I have no clue - sorry.