FreeNAS Sysnthing plugin config.xml path

Hi,

Hoping someone can help me. I don’t recall setting a password for the Web GUI and I’m not able to log in. I understand from reading several threads and the FAQ that I need to edit the config.xml file however I am unable to locate this file on FreeNAS using the Syncthing plugin.

I ran syncthing -path and got this result /root/.config/syncthing/config.xml

But I can’t find that path as is seems that .config does not exist. I search using the following command. find ./ -name config.xml /mnt/data1/iocage/jails/syncthing/root/user/local/etc/syncthing/config.xml

That config.xml file has information about the directories I am sharing but does not contain user and password tags that I need to remove to reset the GUI as per the FAQ.

So I’m hoping someone here can point me in the right direction.

Thanks, Dan

Are you sure it’s Syncthing that’s asking you for a login?

Yes because I’m logged into FreeNAS then I go to pulgins, click on the syncthing plugin and select manage which then opens a new browser tab pointig to

http://192.168.1.193:8384 with the message (is requesting your username and password. The site says: “Authorization Required”)

I finally solved my problem. I upgraded from FreeNAS 11.x to TrueNAS 12.x and then I upgraded the jails. Not sure if that had an impact but after those two upgrades I found the config.xml file in this location where data1 is the name of my dataset and syncthing is the name of my jail.

/mnt/data1/iocage/jails/syncthing/root/usr/local/etc/syncthing

I was able to edit config.xml to remove and lines. Then restart the syncthing plugin and I can now access the GUI.

It’s still strange to me because the the output of the syncthing -paths command still shows the configuration files residing here.

/root/.config/sysncthing

But that directory shows empty when I run the ls command. Go figure. Anyway, I just thought I’d post the solution in case it can help others.

Syncthing shows the config path it would use in the environment it’s run in. If you run it as root outside of a jail it’d use /root/.config/syncthing. If you run it as some other user inside some jail it will show a different path. If you run it on some other machine in a different environment it will show something different again.

That makes sense so why then did the paths command return /root/.config/syncthing instead of /root/usr/local/syncthing in my case?

Because /root/.config/syncthing is the path Syncthing would use if you started it like you did (without --paths). The actual FreeNAS plugin apparently does something else, perhaps forcing that path explicitly with --home.