FreeNAS Plugin - servers not syncing

Hello. Congratulations on the elegant solution; very simple to install and use. Pretty slick.

I had a few problems with one of my FreeNAS servers where Syncthing would use up to 50% of the CPU, but everything in that CPU was unbearably slow. I deleted the plugin and reinstalled it, and everything seems to be working fine in this regard.

Just FYI, first sync between the servers was achieved using ZFS’s replication.

Now on to the problem. Both servers indicate they’re up-to-date. Allright, they should be.

But then I create a txt file in each server, each with one name, and they don’t replicate to the other server.

I tried to rescan but it doesn’t seem to be working.

Any suggestions?

Did you follow the getting started guide? Are the folders shared? Are the devices connected?

Good morning,

Yes, yes, and yes, sir!


1 Like

The folders are in sync. The folder path for some reason is /Sync not ~/Sync as you might have expected, so perhaps you are creating your text file in the wrong place.

1 Like

I don’t know how /Sync would make any difference from ~/Sync, since in the end they both would point to the working dataset. The datasets are correctly passed to Syncthing, and Syncthing sees the datasets (it shows “3 (folder icon)”, indicating the dataset with two sub-datasets I passed to it.

Also, I’m creating the text file right in the share (in the dataset), not messing on where Syncthing mounts it inside it’s jail.

I’m completely lost.

Right, I suggested the ~/Sync as that is default location, so I was assuming your configured path is /Sync, and you put files in ~/Sync.

Anyways, it seems that it does see 3 directories, if you expect it to find files and it’s not finding them, then most likely the reason is permissions. User running syncthing process needs to be able to read write AND execute inside those directories, as listing directory content requires execute permisions.

In FreeNAS’ settings, “jail user” and “system user” for Syncthing’s jail are both root.

The Dataset is using Windows ACL because it’s an SMB share.

I did indeed have to click on “ignore permissions” under Syncthing’s folder settings.

This has historically not proven to be an awesome setup for Syncthing.

Hello mr. Thanks for the reply.

Actually I found another tutorial which involved chmodding the mount points before effectively mounting them (in Freenas, Syncthing runs in a jail, so in order for it to have access to the main “dataset” you want to sync, you have to pass it on to the jail by mounting it to a folder inside the jail, it seems).

So the fix was to create and “chmod 777 -R” each and every folder inside of the jail, replicating the datasets you wanted to mount onto the jail.

Ex.: I have in my Syncthing jail the following folders: /mnt/Share /mnt/TimeMachine

So I mkdir them, then chmod them, then stop the jail, then go to FreeNAS and mount the datasets in those folders. When I restarted the jail, something new happened: it started scanning. It never scanned before, like the folders were empty.

Also, I had to use the “Open” preset for ACL permissions, and that seems to have done the trick.

Now let’s see if it syncs. I have about 2TB of files, and I’m running on a Gb ethernet. But it seems like it’s working now.

Thanks for the input. Best regards!

Ok so I managed the permissions, but both my servers get unbearably slow - to the point I have to hard reset them.

Meanwhile, my dataset folder indicates “Scanning”, but with no progress. Left it for two days (without being able to access anything on the servers except for receiving ping response).

I think the hashing step is bringing my CPUs to their knees - one of them is an AMD Opteron™ X3418 APU, the other is an Intel® Xeon® CPU E3-1225 v6 @ 3.30GHz. 8GB RAM each.

Dataset is around 2.21TB.

Any ideas? :confused:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.