Force syncthing trafic through VPN tunnel?

I’d like to enable synchronisation to my NAS when I’m not in its LAN. For this, I’ve set-up a wireguard VPN server in the LAN to which I can connect from the WAN, from my laptop. The syncthing service is running on both NAS and laptop:



(NAS at its LAN address)


So far, so good.

The problem is that in both GUIs, the other device is listed but shown as disconnected, which puzzles me.

Can I / should I somehow force syncthing to use the VPN tunnel? Or is there another issue or setting here that I must take a look at? Here are the connection settings on the laptop:

Many thanks

Please show screenshots of the entire UI with the respective remote expanded (bottom right).

Thanks imsodin for your reply. Here you go (I assume the folders on the left side are irrelevant; they are all showing ‘up to date’):



Let me know if there is any other information I can provide.

This is a good start :slight_smile:

The NAS has a problem with discovery: If you click on the 2/5 you get more infos on which method the problem is with. Most likely global discovery, as in the windows UI there are no addresses displayed for the NAS.

And then there’s likely a firewall problem: The NAS discovered the windows device, including local addresses. So a connection should work. I’d guess a firewall on windows prevents incoming connections on port 22000. See Firewall Setup — Syncthing v1 documentation

Ok, so I turned off the firewall for the VPN connection (also called ‘ruudwork22’):


But the device do not find each other yet.

Here is the NAS’s Discovery window:

Thanks again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.