Fonts fail to load with 401 error


I have been using Syncthing on a VPS server and it’s been working fine. I recently noticed that I can’t see some of the icons on the web interface anymore:

The output when I run it with STTRACE=http outputs the following:

[DEVIC] 2015/08/11 04:53:35.526068 gui.go:309: DEBUG: http: GET "/vendor/bootstrap/fonts/glyphicons-halflings-regular.woff2": status 401, 15 bytes in 219.24 ms
[DEVIC] 2015/08/11 04:53:36.141824 gui.go:309: DEBUG: http: GET "/vendor/bootstrap/fonts/glyphicons-halflings-regular.woff": status 401, 15 bytes in 507.72 ms
[DEVIC] 2015/08/11 04:53:36.596660 gui.go:309: DEBUG: http: GET "/vendor/bootstrap/fonts/glyphicons-halflings-regular.ttf": status 401, 15 bytes in 273.49 ms

When I try to access those files directly from the browser (Chrome 46.0.2471.2) it works fine.

I also see some of the following, could be related:

[DEVIC] 2015/08/11 04:53:35.306768 gui_auth.go:47: DEBUG: Sessionless HTTP request with authentication; this is expensive.

Any ideas why this might be happening and how I could solve this?

Are you using some sort of proxy? It seems that you either have an outdated cookie (restart your browser) orbyour browser just refuses to provide one (or basic auth) when fetching assets. Clearing browser caches might help.

same problem. Chrome Version 46.0.2478.0

I sometimes use VPN but enabling/disabling that, clearing the cache, restarting the browser didn’t help. However I noticed that it works fine with Safari so I believe it’s a problem with Chrome rather than Syncthing.

are you using adblock plus or similar?

I am, but disabling it doesn’t help. I also tried incognito and with a new profile, no luck.

It may not give much, but running Syncthing with STTRACE=http will show you all requests and their response codes as seen from the server side.

I know this problem from several websites using fonticons… it wont help just to disable it :frowning: you need to uninstall it… (or just try uBlock)

seems to be a Chrome and not a Syncthing bug - see and