Folders synced by syncthing read only

Hi there,

I run syncthing on my Openmediavault NAS and the respective Windows computers. Syncthing is assigned its own user with read/write permissions on the NAS.

Unfortunately, I am encountering two issues: First, from time to time (but it always reproducably happens) I am getting out of sync problems. According to my observations this happens whenever I either rename a directory or file or when an editable file, e.g. a Microsoft word document, has been changed. In the former case syncthing copies the renamed directory, but it does not manage to delete the old un-renamed version. In the latter syncthing does not seem to be able to recognise the correct (=latest) version of the document. There is no conflict meaning the file has only been edited at one location.

The second issue I am facing is permission-related. In some folders, but strangely not in all of them, I cannot delete or edit files on the NAS from my computer. Instead, Windows shows me a prompt to request permissions from the syncthing NAS user. Windows accesses the NAS with a different account, but it has full read/write access to the NAS as well.

My syncthing version on the NAS is v1.23.0, Linux and the Windows computers use syncTrayzor.

I would be very happy if anybody had suggestions to solve one of the problems or even both. I put them together in one thread as I think they might be somewhat related.

Best Scaty

Since Windows cannot replicate Unix/Linux file/directory permissions, it’s best to enable “Ignore Permissions” on both ends of a connection.

Although the user account used by Windows has full read/write access to the NAS network share, it normally only applies to files that it created and doesn’t necessarily have the same permissions for files/directories created by the Syncthing user on the NAS.

There are several solutions, including:

  • From Windows, access the NAS using the Syncthing user account.
  • Put both users in the same group on the NAS and make files/directories group readable/writable.
  • OpenMediaVault uses Samba to provide SMB shares for Windows. Samba’s “force user” and “force group” parameters can be used to override the effective user reading/writing even when there are multiple user accounts accessing a share.
  • The nuclear option is changing the umask so that all files created by the Syncthing user on the NAS are world readable/writable.


thanks for your reply.

“Ignore permissions” was already ticked, but your hint to have a closer look at the file permissions seems to have solved my problem. I updated the access control list in Openmediavault by enabling the “folders and subfolders inherit all permissions” function.

I really hope this was finally it.

Best Scaty

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.