Folder won't stop scanning


(Gelbbauch) #1

I’ve been using syncthing for a while but it has been extremely finicky for me but now I can’t really stop this.

So I had to reformat my desktop and re-setup syncthing on the new install. I didn’t get it quite right for whatever reason as it looked like it never finished syncing nor would it detect directory changes and send them over. So I have it configured on a headless VM and my windows desktop. After reinstalling on windows, the headless linux system will keep on rescanning and rescanning incessantly. The sole syncthing process alone is using half my RAM and nearly all my CPU, sometimes load goes up to over 2 and is over 1 where it doesn’t need to be. Logs aren’t updating. Restarting the service does nothing, same with reboot. The only error I see is when expanding the folder info: " Rescans 1h Failed to setup, retrying "

I tried even removing the folder from syncthing and re-adding it. Still does the same even though it should have a new ID. At least I got a warning saying the old marker was gone. Updating didn’t help. Running v0.14.48, Linux (64 bit) from the repo.

I’m not quite sure what to do on this. Any guidance? I’m stuck with my projects and moving data around until I get this back up.


(Audrius Butkevicius) #2

This is missing a lot of context, how big is the folder is in terms of number of files and size, what type of machine is it in terms of cpu and ram (half the ram means nothing), did the logs confirm that the initial scan was completed or is this the initial scan, what’s in the folder, perhaps it’s something that is permanently changing such as some database, hence it’s constantly scanning, is disk io the bottle neck?


(Gelbbauch) #3

It looks like Syncthing is supposed to rescan every minute or hour, but it starts scanning, completes to 100%, occasionally gives me that “Failed to setup” error then immediately starts scanning. Logs don’t display anything most of the time, otherwise it just says it’s starting a scan. No reason why.

The directory holds mostly static files. Iostat shows the drive where the directory is, is largely idle with no writes.

There is a disk io bottleneck but this never came into play before as far as constantly scanning. Shouldn’t be an issue if the drive is idle.

The rest of the folders on this drive work as expected. It’s just an external hard drive I’ve passed through to a VM running latest version on Centos 7.5.


(Audrius Butkevicius) #4

Please provide logs and screenshots.


(Gelbbauch) #5

I think I figured it out. I deleted the folder and readded it. It was still kind of doing the same thing but after a while, it seemed to have worked itself out. I’ve had some other issues like some puller hanging on a particular file. Anyway it seems that after getting rid of the dot files at both locations and readding the folder seems to fix some problems.