Folder with 'ignore delete' creates .pending duplicate after deleting file from source

Hi there, Im new with syncthing and got everything setup. Enabled ‘ignore delete’ on the folder (NAS) where i store my photo’s and video’s from my phone (source). After i set these settings i uploaded all from the source folder to the NAS. Then, to see if the ignore delete function works, i deleted one video from the phone folder.

After that i checked the folder on my NAS. The photo was still there but there was also a duplicate starting with ‘.pending’ I attached a screenshot of these files.

I wanted to use syncthing to backup family photo’s and video’s from my phone to my NAS so i can clear up my photo folder. Is there a way to prevent syncthing making these duplicates? Or am i missing something?

.pending is not something that syncthing does/creates, you should check for other software running against that folder.

As far as i know i haven’t got anything else running on that folder. It’s a shared folder on my Synology NAS that is only used by synology photos. I had used photo backup from ds files and ds photos app on my android phone but i both disabled that photo backup before i started with syncthing. I double checked it and it’s still disabled. Could i miss anything else?

Just tried it again. Made a new photo and put it in source folder. It uploaded to the NAS. After that i deleted it on my phone. Checked the NAS. Issue still happens.

Syncthing temp files are named .syncthing.(original-filename).tmp. We can’t know what you’re missing, but it’s not Syncthing that creates that file.

I would think so. I needed to reorganise my map structure in docker so i moved syncthing and started over. Before i even got to syncthing i used photo backup from synology’s android photos and ds file apps. I thought maybe this was a leftover from these apps although i disabled photo backup in it.

So i reinstalled syncthing, i changed the map folder names and set up syncthing as if it was new. I connected my phone to the server, made a folder in syncthing on my server, made it recieve only and enabled ‘ignore delete’ and shared it with my phone. On my phone i set it up as send only. It uploads it’s photo’s and after uploading everything is on my server. Now on my phone i deleted a test photo i made and again the same thing happens in the sync folder on my server. It duplicates the photo and adds .pending before it as i showed in my previous screenshots.

I looked at the programs i’m running on my server and none of them are accessing this photo folder, except for synology’s own photo program ‘photos’. Also checked this app and it only reads the folders and images inside the shared ‘photo’ folder. I also asked around on a synology discord server but no one could think of a program that would do this that is installed on my NAS.

So here i’m back again in the hopes someone does know why this happens.

Considering Calmh’s answer about the naming pattern of temp file names i’m still guessing this is a syncthing issue. I’ve never had a program running on my NAS that would create copied files and renames them with .pending. Considering syncthing creates other folders and temp files beginning with the point and then syncthing (.syncthing) still makes me think this is a syncthing related issue.

I don’t know what to do anymore :stuck_out_tongue: I hope all my information helps solving this issue. If you need more information please let me know.

Preceding filenames with . is the standard way to create hidden files in Unix-like systems. It has nothing to do with Synctihng per se, and many other programs use the same method to hide their files.

Regarding the .pending- files themselves, I have only managed to find https://forum.resilio.com/topic/72967-a-bunch-of-pending-files, which would indicate that the phone software is the culprit.

In connection with Synology NAS or any installed APP on it, this ending would also be new to me. This appendix is also new to me in other respects. Including the ending “.pending- *” in the stignore on the smartphone might be the solution.

Doe you use Resilio in parallel in any case? If so, you have to add the work files and TMP files types to the ignore list in the respectively other application.

Thnx for the info andy and tomasz! I think it might be google photo’s app which i use for my photo’s ob my phone.

How can i put the .pending files in the ignore list? Should i do this on the server or my phone? Also, if i press the ignore button on the syncthing app on my phone it says it doesn’t have a text editor. What app should i use for this (only if needed)?

I would do it on the phone. There is a Web GUI button on the slideout left menu, which opens the same interface as you have on your desktop. There you can add ignore patterns directly.

Adding .pending-* should be enough.

1 Like

Thank you very much! Did a test and it worked. I guess the .pending files are being created in Google photo’s because deleted images are sent to a recycle bin instead of being definitely deleted.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.