Folder that does not synchronize .... whi? [LONG]

Hi . . .

I have six Windows devices, Android and a Synology NAS.

All the devices synchronize some folders perfectly with the NAS without my having assigned further permissions than those proposed by default.

This premise to state that Syncthing is already working well and that the new operation I intend to perform will be done on devices already existing on Syncthing!

My intention is to have in each of these 6 devices a folder shared between all devices. Unfortunately, at the beginning a mysterious problem prevents me from synchronizing the second device with the first!

At the start, on the first device an ACER laptop I created a folder that I called “SharedSyncthing”. Inside this folder I have placed a files and a folder with some files.

I opened Syncthing on (existing device) Acer (ID: 24BDGKP - ******* - ******* - ******* - ******* - ******* - ******* - D3RH6AN)

I created a new synchronization between Acer and NAS device (NAS already existing on Syncthing) which is “Connected (not used)” AHG2DXD - ******* - ******* - ******* - ******* - ******* - ******* - P7UFFAJ:

  1. In the “General” tab I clicked on “Add folder”. At the “Folder Path” I indicated “D:\SharedSyncthing”. In “Label for the folder” I indicated: “SharedSyncthing”
  2. In the “Sharing” tab I have checked (for now) the only box that points to the NAS device.
  3. In the “File Version Control” and “File Exclusion Schemes” and “Advanced” tabs I left everything as default (In the “Advanced” tab under “Folder Type” Send & Receive is selected by default)
  4. I saved. Now the “Shared Syncthing” folder has appeared on Syncthing on the Acer laptop whose ID is: 2g *** - *** vk
  5. After saving, the “.stfolder” folder has been created in the shared folder on the Acer laptop.
  6. On Syncthing in the NAS I immediately received the invitation to share the folder with the same ID: 2g *** - *** vk - All data set on the Acer laptop synchronization are replicated correctly and in the “Sharing” tab is selected (rightly) only Acer. - On the NAS file manager I found the correct path to the folder “/volume1/homes/XXX-XXX/Drive/CondivisaSyncthing” that I used in Syncthing (as I have already done for all the other folders).
  7. To confirm the sharing on the NAS for the “SharedSyncthing” folder I get “Not synchronized”.
  8. In an attempt to start the synchronization, I also subsequently added to the “Shared Syncthing” folder on the NAS the “rslsync” and “sc-syncthing” permissions for reading and writing (which in all other synchronizations that are already working there are not), without success.
  9. On the SharedSyncthing folder on the Acer laptop, I have enabled “Advanced Sharing” allowing “Everyone” to read and write.
  10. I also tried - unsuccessfully - to check the “Ignore permissions” box in the “Advanced” tab.

Why do I get the “Out of sync” warning?

Sorry for the length!

Can you post screenshots of the Syncthing Web GUI from all affected devices.

Waiting for your answer, on Syncthing on Acer, I shared the SharedSyncthing folder with a second device, the Huawei smartphone (the only device on which I can do a second test for now, the others are in another location). The sharing notification has arrived on Huawei that I accepted. I uploaded a file to the shared folder with the Acer and the file immediately appeared in the shared folder on the Acer.

So the problem only occurs for the folder in the Synology NAS which must have some missing lock or permission that I can’t imagine. Still, I already had this sync and it worked perfectly with the NAS. But now I can’t get it to work.

Second attempt: right now through Syncthing android on the Huawei smartphone I shared the SharedSyncthing folder with the NAS. After a while, the newly added file appeared on the NAS. I just can’t explain the reason for that mistake …

Can you click on the 2 elements that can’t be synchronised and post a screenshot of what is there?

Moreover, comparing the last two images, the error displayed does not appear to exist on the second image

In short, despite the red “Not synchronized” warning, it seems that any object I add to the SharedSyncthing folder on any device, (for now only the Acer laptop and Huawei smartphone), is added by the Syncthing software for Synology, even on the Synology NAS … I do not know what to think…

I’ve a feeling that this is caused by not ignoring permissions. Please try to tick the “Ignore Permissions” box in the folder’s settings on all devices and see what happens. There’s a mix of three different operating systems (and probably different filesystems as well), so ignoring permissions is a good idea anyway.



On the Syncthing NAS app, at the single synchronization item “Shared folder”, in the options in “Edit”> “Advanced” I applied the flag “Ignore permissions” - as suggested by @TomasZ86 and as also done by me at least twice without success. Only this time it worked, the red “Not synchronized” error disappeared and “Synchronized” finally appeared in green.

1 Like

On Synology, the only sensible way to use Syncthing is to check that option to ignore permissions. In fact, I added it as a default to the most recent package release on SynoCommunity. But unfortunately that only applies for new folders created after a fresh installation, so might not have helped in your case.

Go ahead and check that option for every existing folder on the NAS, and ideally also on folder defaults so you won’t need to remember it in the future.


Do you mean this option?

Yes, exactly. Make sure to also check it on all existing folders (Edit Folder button).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.