Folder syncing on 3/4 devices. Other machines marked 'Unused' on fourth


I’ve been having a persistent problem and I haven’t seen a similar issue posted here before. I have a folder that is shared among four computers, two running Arch (devices 1&2) and two running MacOS (devices 3&4). Devices 1&2 are machines at my office that I administrate and internet-facing, and devices 3&4 are laptops that travel back and forth between home and office. Syncthing is version 14.38 on all devices.

For a while, this folder was syncing fine across all devices, and then one day it stopped on device 4. I tried removing the folder from this machine hoping to prompt a fresh resync from one of the other remote devices. However, when I tried to reshare the folder from the remote machines, the “Remote Device wants to share Folder with you” prompt never showed up.

I next tried to remove all the remote devices and then re-add one at a time. This worked, but when I tried to re-share the folder with device 4, the prompt still never showed up.

Right now, both devices 3&4 are at home, and device 3 is syncing fine with devices 1&2. However, on device 3, it says “Device 4 Syncing (0%, 13.8GiB)”, while on device 4, all remote devices are marked “Unused”. On Device 4, the Folders pane is empty.

I’m stumped. Should I completely reinstall syncthing from each device? Is there another diagnostic I can look at to figure out what’s going wrong?

Thanks in advance for your help!

Best, Dan

If you ignored the suggestion to share, it will not show up. You can manually share the folder from the folder settings dialog with other devices.

Thanks for the reply. I did not ignore the suggestion to share on any of the devices. Instead, that suggestion never appeared.

I have tried manually sharing the folder from multiple devices multiple times before and after restarting those devices.

My point is that you can manually share it from both sides, then you don’t need to wait for the prompt (as you establish the relationship yourself).

From what you are saying it seems the devices can’t connect hence why you are seeing these issues.

Sorry I must be confused. When you say manually share the folder, I’m understanding you mean the click on the folder on the remote device -> Edit -> Share With Devices -> Check box next to device name.

It seems to me that I can only do this from devices 1-3, because I want to pull from their state to device 4. I have tried doing this, but the suggestion to share never appears on device 4.

Are you suggesting that I use a tool like rsync to pull the remote folder to device 4, then ‘Add Folder’ to syncthing on device 4, then share it with the other machines? I searched, but didn’t see any documentation on how to ‘manually share folders’.

As for the question of devices connecting, I don’t think that is the problem either, although I could be wrong. Here is the view of the Remote Devices pane on Device 4 (the problem device). It looks to me like it is connected because the Download and Upload rate is being displayed. Additionally, if I turn off syncthing on of the other other devices, this display changes to display the “Last Seen” time and date which is around the time syncthing is turned off on those devices.
15 PM

Sorry, but I don’t understand what you do not understand. You added 3 devices on this device from which you are sharing the screenshot, but you have not shared any of the local folders with them.

If you don’t have any folders, I suggest you add them (with the same folder ID), and share them with these devices.

In syncthing’s terms if you have devices A and B and folder F, A needs to share F with B, and B needs to share F with A, as otherwise it won’t work, and it’s not enough to share it one way (which is what is happening in your case).

Oh, I didn’t realize that you were supposed to initiate sharing from both devices. Whenever I’ve used syncthing I’ve done the following (using Syncthing’s terms)

  1. Add device B on device A
  2. Accept “Device wants to connect” on Device B
  3. Add Folder F on Device A and check to share with Device B
  4. Accept “Device A wants to share Folder F” prompt on Device B
  5. Watch as Syncthing syncs Folder F

This ‘one-way’ sharing model is what I found on the Syncthing tutorial.

It sounds like you’re suggesting the following:

  1. Add Device B on Device A
  2. Add Folder F on both computers using the same Folder ID
  3. Select to ‘Share Folder F with Device A’ on Device B and vice versa

Is that correct? If so, it means that if Folder F already exists on Device A and I want to share with Device B, I need to first add an empty folder on Device B with the same Folder ID as on Device A. I’m trying this right now and will update if it works.

That is correct. The only reason the prompt might not come up for connected devices is if you pressed ignore at some point before. There is a section of ignored folders in the config somewhere, you can verify that.

1 Like

Great, we have ‘Up to Date’! Thank you for your help. I made a donation to Syncthing as a token of thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.