Folder Path Changed Behaviour?


I’ve done this plenty of times before without issue - but it looks like the behaviour has recently changed (currently running 0.14.48 under macOS):

I’ve tried to add a folder at /Volumes/AC HD/Updates - Current - so have entered exactly this in the folder setup (as I have done before).

In response, I’ve got the following error in the log:

2018-07-12 11:03:13 Creating directory for "Updates - " (*****-*****): mkdir /Volumes/AC/: permission denied

I then tried escaping spaces by entering /Volumes/AC\ HD/Updates\ -\ Current as the Folder Path - and got the following error:

2018-07-12 11:39:16 Creating directory for "Updates -" (*****-*****): mkdir /Volumes/AC\ HD: permission denied

(Note also that the Folder Name is being listed as Updates - instead of Updates - Current, despite what’s listed in the Folder Label.)

Is this just me?



That’s weird - for me it works as expected on linux and firefox 61. Maybe this is a JS/browser issue - which one do you use?

Hi Simon:

Many thanks for this; I’m using Safari 11.1.2 on macOS 10.13.6 - only released earlier this week.

I’ve just tried it with Firefox 61.0.1 - and all works as expected. Hurrah!

Best wishes,


Would be interesting to know whether our code is to blame or Safari’s JS engine. However I am totally out of my depth for that question, so from my side you will have to live with using firefox for creating Syncthing folders atm :wink:

Hi Simon:

No worries at all! :slightly_smiling_face:


I’m using firefox myself on OS X. Its weird this happens on safari (not verified myself). Maybe we should create a bug report for this and also let other people verify this behaviour?

Well, verify it if you have a mac, and if you can repro, open a issue, or a PR if you find a way to fix this.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.