Folder "name" isn't making progress


I’m running the latest version of syncthing on my Ubuntu 15.04 Notebook (ext4 file system) and my raspberry pi running the squeezeplug/max2play image (external hdd - fat32). I’m experiencing the same “folder isn’t making progress” - issue many users seem to have, but I couldn’t find a solution in any of the threads so far.

I tried to erase the index, however that did not work.

I seem to get 2 different root causes

  1. invalid argument (its a rather long path and the filename contains German Umlauts)
  2. no such file or directory (rather long path filename does not contain German Umlauts)

Filenames or path don’t contain any other special characters. That happens with about 160 files.

[VKTOX] 01:27:10 INFO: Puller (folder “Dokumente”, file “Privat/sonstige wichtige Dokumente/2013-06-05, DateimitUmlautÜ.pdf”): dst create: open /media/usb0/media/documents/Privat/sonstige wichtige Dokumente/.syncthing.2013-06-05, DateimitUmlautÜ.pdf: invalid argument

[VKTOX] 01:28:37 INFO: Puller (folder “Dokumente”, file “Privat/Wohnen/Wohnungen/Ortsname/Straßenname/2012-07-01, Mietvertrag - Ort - Straße.pdf”): dst stat dir: stat /media/usb0/media/documents/Privat/Wohnen/Wohnungen/Ortsname/Straßenname: no such file or directory

I am the owner of the files (not root) and I had the files backuped on the hdd before. The raspberry pi should be set to utf8_de_de so I don’t think Umlauts should make a problem. Might the path be to long for a fat32 partition? I don’t think so because I already had the files on it.

I know there is already this thread about the same topic but it doesn’t look as if they found a solution and it is for an older version, thats why I startet a new thread.

I didn’t filed a bug yet, but probably will do so in case it is one (and not a stupid mistake on my side).



The “no such file” could conceivably be some kind of character encoding issue, but the “invalid argument” is stranger. The file names look FAT compatible to me… Among the 160 files, do all contain umlauts or other accented characters?

well that was fast…

most files have the invalid argument issue, and yes it seems all of them have Umlauts. I think no files containing Umlauts were synced after all.

the few with the no such file issue don’t have Umlauts.

Can you manually create a file with such a name on that device? The error is returned by the OS and I don’t think we do anything especially magic that should trigger it…

OK, that probably did the trick (also with samba issues I had). I had to add locale options to the usbmount.conf, otherwise the HDD was mounted with utf16 charset.

I’ll check whether everything works.