Finding logfile on Linux running as systemd service

Hi all, first of all thanks for the amazing tool

I have a quick question. I am running syncthing in Fedora Linux, running it as systemd service, which “.service” file has been modified to run with the following options

# ExecStart=/usr/bin/syncthing serve --no-browser --no-restart --logflags=0
ExecStart=/usr/bin/syncthing serve --no-browser --no-restart --logflags=11 --audit --logfile .syncthing.log

Now, I can see the audit files inside ~/.config/syncthing, but I can’t find the logfile anywhere (tried sudo find / -name ".syncthing") and this didn’t brought up anything)

Any ideas what I may be missing here?

journalctl -u syncthing (or whatever the service is called, potentially syncthing@someuser)

And regarding the --logfile .syncthing.log custom option in your systemd file, I have no clue what the working dir of a systemd service is - you should definitely use an absolute path there. As to the find command you used, find / -name ".syncthing": That won’t turn up anything as it should be -name .syncthing.log according to your systemd unit file.

Yes, I should have mentioned that one I tried and it works indeed. It does so independently of the --logfile option, though, so maybe it means that the “–logfile” switch has not effect when running as a systemd service?

Yes, that was a typo, I used “-name .syncthing.log”. I will try the abs path though and comment back

Confirmed, it works with an absolute path:

–logfile /home/user/.syncthing.log

Thanks for the help

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.