finding cause of 'access is denied' failed items on a read-only onedrive/sharepoint folder


I’m trying to sync 3.3 gb worth of read-only sharepoint/onedrive files and folders (4300 files) on windows 10 to ubuntu 20.04. I’ve set the source as send only, target as receive only.

Out of the 4300 files, I have 15 failed items. The reason given for the failed items is ‘access is denied’. I have access to the files, I can open them on the source system.

In the log I see ‘normalizing path’, then ‘access is denied’. I’m imagining that maybe syncthing doesn’t like the path, is trying to modify it, and can’t because the folder path is read only ?

I don’t particularly see why there are problems with these 15 files, they have accented characters in the path and files names, but so do others.

Some of them have the French number notation N° in the path, which I imagine could be a problem, but not all. In any case as they are read-only I don’t have the option of renaming them.

My questions are :

  • how can I figure out what exactly is going wrong with these files
  • does anybody have an idea for a workaround/fix that would enable me to get them to the target system (possibly renamed if necessary, though I have read the conversations regarding the underlying problems with this kind of approach if it was to be automatized in ST)

many thanks


Item paths in Syncthing must be made-up of valid UTF-8 encoded unicode characters for interoperability. If your system uses something else, Syncthing tries to normalize filenames. Maybe your filesystem or program to mount/sync sharepoint/onedrive has an option to change encoding (maybe it’s ISO-something/Latin for you?).

In this case I think it’s about Windows/normal-Unix normalization vs Mac. With auto normalization turned on, weird Mac normalizations will be corrected to regular normalization on non-Mac systems. This needs to happen for the sync to work properly.

thanks for the quick reply ! I can then safely just turn off normalization if I’m not intending to sync this folder to macs then ?

No. You can turn off normalization and Syncthing will skip the affected files with some other error (wrong normalization form, I think). The correct solution is to correct the file names for the system accessing them.

ok thanks for the quick replies ! and great work on ST by the way, keep it up ! :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.