Filesystem Watcher Errors - Permission denied - Synology Docker

Hi guys,

I’m brand new to this forum, so please guide me, if I missed something that should be obvious.

Long story short…

  • I used Syncthing for at least for 2 years on my Synology as a package installation
  • Now I moved to a new Synology NAS and moved to Docker (synchting/synchting). Basically I copied via SSH the config files and folders from my old NAS to the new Docker container folder.
  • PUID and PGID is matching a Synology user / group, that has r/w priviliges on the Sync folder and the docker folder with the Syncthing config.
  • The devices found each other, folder path’s are same. I attached some pictures how it is configured.
  • The sync itself works smooth and files are synced all around, at least I found no mistakes. I tested a lot with new folders and with pre-exiting folders (existing on both sides) server and clients on my old NAS

BUT… I still get an error message “Filesystem Watcher Error”, “error while traversing” : permission denied

Question: What does this error indicates, if the sync on these folders seems to be ok? Is there a way to figure out where and what permission is missing?

Thanks for any help with this! Also please let me know, if you need further details from me.

Regards Oliver

1 Like

I have had also this problem for a long time and have not been able to fix it to this day.

The reference to the search link does not help. On the contrary, my contributions to my unsolved cases also appear there.

However, I can say so much, it doesn’t have a negative effect in my case. I run three Synology with Syncthing and I have the same problem on all of them, but none of them really have an sync problem.

In the case shown here, Syncthing manages 59 peers and over 2.6 TB of data without any problems, which are completely synced with one of the Synology, and largely with the third.

1 Like

The situation is simple, but thanks to Synology-permissions that noone understands the solution isn’t known:
Syncthing cannot set up to continuously watch for changes because of a permission error. The solution is to fix the permissions. However while that’s a simple thing to do on a sane system, it is not on synology. There have been attempts at wiping all ACLs, but as far as I remember they come back on upgrades. So even if it helps it’s not a permanent solution.

There’s two simple solutions:

  1. Get something else than Synology, preferably something running something that merits the name OS, not some NAS-wodoo-wonder-system.

  2. Disable watching for changes. Changes will still be picked up in regular full scans.

1 Like

In fact, Synology’s is something special with ACL’s. Synology has put a second ACL hood over the “normal” Linux authorizations to illustrate this, which I also find not entirely happy, but it is easier for the simple user.

On my 3 Synology there are 2 peers out of x peers and in this example here now 2 out of 59 peers. Since everything is going well anyway, I don’t do anything.

However, to take up the remark

other NAS have also any other OS, similar to Synology DSM, and not all simple users understand what is in the deep linux world and in which way is to handle. For such users, normal Linux servers are a book with seven seals, therefore it is justified for normal users, that’s the today way.

1 Like

Thanks a lot for all the replies! Of course I researched this forum before posting for a solution, but indeed I missed the topics about ACL issues with Synology NAS systems. To be honest I really wanted to have this 720+ NAS-wodoo-wonder-system :wink: Simply because I’m a happy user on all other ends for more then 5 years.

And due to your help I solved the issue (at least) for now. Sorry, I’m not a SSH expert, so I “repaired” it with these steps:

  1. Stop Synchting
  2. Rename root share folder “_OLD”
  3. Create new shared folder with same name as before and new priviliges
  4. move data from old folder to new folder
  5. Add priviliges Synchting user / group to the folders that needs to be synced
  6. Start Synchting

I still have one question… The folder I want to sync and the Synchting docker folder have r/w privileges. So if files are synced (created, modified and deleted) privilegeson these levels should be ok. Also in my case file .stignore and folder .stfolder are created and my special Synchting user can read and write to it.

So what makes Filewatcher different, because he is running with the same privileges, right? Is the Filewatcher only reading within the Synced folders and writing to the config folders?

Best regards


This worked for me(DS220+) Grant application rights to the Local group Users.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.