Filesystem Watcher Error inotify back after upgrade & Notice

I thought I had this fixed, but it apparently came back after 1.10:

!FILESYSTEM WATCHER ERRORS For the following folders an error occurred while starting to watch for changes. It will be retried every minute, so the errors might go away soon. If they persist, try to fix the underlying issue and ask for help if you can’t. Support ACADJOBS1 failed to setup inotify handler. Please increase inotify limits, see https://docs.syncthing.net/users/faq.html#inotify-limits

Do I have to increase the inotify limits after each upgrade? There is also the error that came back of:

! NOTICE 2020-10-06 06:54:12: Syncthing should not run as a privileged or system user. Please consider using a normal user account.

The errors are on a WD MyCloudEX2Ultra with a form of linux operating system. No problems on windows 10 pc’s. It has been relatively quiet.
tia Here’s a screen shot, which I should have done to start with.

I suggest you check the logs as to what the actual failure is.

Did you persist the inotify limit change?

Yes, I re-ran the command

echo “fs.inotify.max_user_watches=204800” | sudo tee -a /etc/sysctl.conf

But it didn’t fix it. The log has these entries since yesterday:

2020-10-10 23:04:15 Detected 1 NAT service
2020-10-10 23:04:22 quic://0.0.0.0:22000 detected NAT type: Port restricted NAT
2020-10-10 23:04:22 quic://0.0.0.0:22000 resolved external address quic://xxx.xxx.xxx.xxx:22000 (via stun.syncthing.net:3478)
2020-10-10 23:04:32 Completed initial scan of sendreceive folder "ACADJOBS1" (ACADJOBS)
2020-10-10 23:04:51 Joined relay relay://xxx.xxx.xxx.xxx:XXXXX
2020-10-10 23:05:08 Error while trying to start filesystem watcher for folder "ACADJOBS1" (ACADJOBS), trying again in 2m0s: failed to setup inotify handler. Please increase inotify limits, see https://docs.syncthing.net/users/faq.html#inotify-limits
2020-10-10 23:07:09 Error while trying to start filesystem watcher for folder "ACADJOBS1" (ACADJOBS), trying again in 4m0s: failed to setup inotify handler. Please increase inotify limits, see https://docs.syncthing.net/users/faq.html#inotify-limits

and so on.

Sure, that writes the setting to sysctl.conf, but it doesn’t actually apply the setting. I think it’s sysctl -p as root to actually apply the settings (or reboot).

1 Like

I think it took this time, or for now at least. I ran:

echo “fs.inotify.max_user_watches=204800” | sudo tee -a /etc/sysctl.d/90-override.conf

to which it returned, “no such file or directory” or similar.

So I ran:

sudo sh -c ‘echo 204800 > /proc/sys/fs/inotify/max_user_watches’

and rebooted, and it is working now. I also logged in to the NAS as a user other than administrator, and I didn’t get the message about the login type.

It’s running smooth and quiet now. Well, it always runs quiet, I suppose. I may be over my head here, but I am giving it the old college try. I’m not proficient at linux, and I am being very generous by saying that much. I know about a handful of commands, and I mean counting fingers. thanks for the help, jts

1 Like