Files get deleted in remote folder on PC

Hey guys.

Just started using Syncthings and it’s great :+1: Doing a lot of testing before go live :slight_smile:

I have a Samsung S23U phone where I save some files in a directory, so I created a folder in Syncthing as Send only. All other things are defaults (Except File pull order which is Newest First). File Versioning is set to None.

On my computer, Syncthing has a folder which is Receive only. It works great and it watches for any changes (new files that I add) and syncs them over. Perfect.

My problem: When I delete the files from my phone it deletes them on my PC too. I tried so many configurations mainly the ignoreDelete in Advanced configuration. It still deletes everything from the folder on my computer when I delete them on my mobile. How do I prevent this from happening? What am I doing wrong?

Syncthing Version v1.27.3

Syncthing-Android Version: 1.27.3

This needs to be set on the device which receives files, not the one that sends them. In your case, you need to enable the setting on the PC. Please also make sure you read up to understand any potential caveats of this specific setting which is normally not recommended.

Thanks for the reply. Sorry, If I didn’t mention clearly. I’ve set this on the device which receives the files so that is my PC. I verified the .stignore file and the parameter is there. I also read the docs is how I found out about the ignoredelete.


That’s not where you set it :sweat_smile:. Please clear out the whole .stignore file and then in the Web GUI, go to Actions → Advanced → Folders → your folder in question and tick “ignorePatterns” there.

I’d also advise to read up if you want to use actual ignore patterns.

Thanks for the reply. It works now the way I wanted but I had to check both of these checkboxes:


Thanks for your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.