Fatal error while syncthing start

When I run syncthing, I get this error:

fatal error: unexpected signal during runtime execution [signal 0xc0000095 code=0x1003f addr=0x0 pc=0x468a64]

runtime stack: time.now(0x9a, 0x45aee1, 0x7ffe0008) /usr/local/go/src/runtime/sys_windows_386.s:429 +0x14

goroutine 1 [running, locked to thread]: goroutine running on other thread; stack unavailable

goroutine 2 [runnable]: runtime.forcegchelper() /usr/local/go/src/runtime/proc.go:90 runtime.goexit() /usr/local/go/src/runtime/asm_386.s:2287 +0x1

and I can’t even see any log comes out of it, what’s the problem…?

P.S. Running this on a XP Home SP2 @2.40GHz 1GB Ram

Can you post the full log? I.e. the panic log file that was created. At least the stuff leading up to the part you posted is interesting. Including the startup stuff about what version you are running etc.

I don’t see any log being generated.

Isn’t it locate at C:\Doc and setting\User\Application Data\Syncthing\ ?

If no log, can you post the entire output you get, wherever it is you get it?

I get this when I run it from cmd, as I only type in syncthing without any parameter

and here is all the output(I think):

fatal error: unexpected signal during runtime execution
[signal 0xc0000095 code=0x1003f addr=0x0 pc=0x468a64]

runtime stack:

runtime.gothrow(0x990ac8, 0x2a)

        /usr/local/go/src/runtime/panic.go:503 +0x67 fp=0x7fd90 sp=0x7fd84


        /usr/local/go/src/runtime/os_windows.go:36 +0x53 fp=0x7fda0 sp=0x7fd90

time.now(0x194, 0x45aee1, 0x7ffe0008)

        /usr/local/go/src/runtime/sys_windows_386.s:429 +0x14 fp=0x7fdac sp=0x7fda0


        /usr/local/go/src/runtime/mgc0.go:25 +0x21 fp=0x7fdbc sp=0x7fdac

runtime.unixnanotime(0x73816b3c, 0x9df2)

        /usr/local/go/src/runtime/mgc0.c:2011 +0x28 fp=0x7fdcc sp=0x7fdbc


        /usr/local/go/src/runtime/mgc0.c:1463 +0x35d fp=0x7fef8 sp=0x7fdcc

        /usr/local/go/src/runtime/mgc0.c:1371 +0xd2 fp=0x7ff18 sp=0x7fef8


        /usr/local/go/src/runtime/asm_386.s:266 +0x50 fp=0x7ff1c sp=0x7ff18


        /usr/local/go/src/runtime/proc.c:818 fp=0x7ff20 sp=0x7ff1c

goroutine 1 [garbage collection, locked to thread]:


        /usr/local/go/src/runtime/asm_386.s:208 fp=0x1144be9c sp=0x1144be98

        /usr/local/go/src/runtime/malloc.go:469 +0x1aa fp=0x1144bebc sp=0x1144be9c

runtime.mallocgc(0x8, 0x873180, 0x0, 0x0)

        /usr/local/go/src/runtime/malloc.go:341 +0x2c4 fp=0x1144bf14 sp=0x1144bebc

runtime.newobject(0x873180, 0x0)

        /usr/local/go/src/runtime/malloc.go:353 +0x48 fp=0x1144bf28 sp=0x1144bf14

errors.New(0x9096c8, 0xb, 0x0, 0x0)

        /usr/local/go/src/errors/errors.go:10 +0x38 fp=0x1144bf40 sp=0x1144bf28


        /usr/local/go/src/io/io.go:21 +0x56 fp=0x1144bf5c sp=0x1144bf40


        /usr/local/go/src/hash/hash.go:43 +0x3f fp=0x1144bf60 sp=0x1144bf5c


        /usr/local/go/src/crypto/sha256/sha256block_decl.go:11 +0x3f fp=0x1144bf64 sp=0x1144bf60


        /go/src/github.com/syncthing/syncthing/cmd/syncthing/verbose.go:129 +0x45 fp=0x1144bfcc sp=0x1144bf64


        /usr/local/go/src/runtime/proc.go:58 +0xbd fp=0x1144bff0 sp=0x1144bfcc


        /usr/local/go/src/runtime/asm_386.s:2287 +0x1 fp=0x1144bff4 sp=0x1144bff0

goroutine 2 [runnable]:


        /usr/local/go/src/runtime/proc.go:90 fp=0x11448ff0 sp=0x11448fec


        /usr/local/go/src/runtime/asm_386.s:2287 +0x1 fp=0x11448ff4 sp=0x11448ff0

created by runtime.init繚4

        /usr/local/go/src/runtime/proc.go:87 +0x25

So that’s before it even prints what version it is and so on? Then no idea, sorry. Corrupt download maybe?

That’s exactly what appear after I press enter, nothing else, not even a log, I downloaded a flash copy of zip from githhub and extract it on the computer and run it, the result is the same, not sure if it’s some sort of environment problem?

Maybe. You haven’t told us anything about the environment, but I’m guessing some variant of windows based on you mentioning zip. Letting us know what you’re running might help. The


@JinxGenius: Are you sure, you have the correct version? (syncthing-windows-386-v0.11.25.zip)

Did something change since 0.11.15, which could be causing problems on 32bit Windows? That version was working fine:

:facepalm: Sorry, missed that.

Yes, I’m sure I downloaded the syncthing-windows-386-v0.11.25.zip, every other machine works fine, except this one, that’s why I kinda wonder what difference happened to this computer, but I couldn’t really tell by this output unless I have to read to whole GO compiler and the whole source code to debug it. Orz

You should try downloading go compiler, compiling hello world and seeing if it crashes. If not, try compiling syncthing, and see if that crashes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.