"Failed to join https://relays.syncthing.net/endpoint due to an internal server error: test failed" when starting relay for the first time

Hi! I just started using Syncthing and would like to contribute with a relay as well. But I can’t due to following error:

$ strelaysrv -debug -ext-address=hagfjall.se:22067 -keys /etc/relaysrv/ --status-srv= main.go:123: strelaysrv v0.14.7+8-g891ff38 (go1.7.1 linux-amd64) jenkins@build.syncthing.net 2016-10-03 03:49:00 UTC main.go:129: Connection limit 3276 main.go:168: ID: INWONPC-E66F7IQ-3VJ4BJ2-EHKRL3G-ZBQ7TVO-L2333X2-MIOCCLK-BWFQ6QR main.go:218: URI: relay://31.208.66.202:22067/?id=INWONPC-E66F7IQ-3VJ4BJ2-EHKRL3G-ZBQ7TVO-L2333X2-MIOCCLK-BWFQ6QR&pingInterval=1m0s&networkTimeout=2m0s&sessionLimitBps=0&globalLimitBps=0&statusAddr=&providedBy= main.go:221: !!! main.go:222: !! Joining default relay pools, this relay will be available for public use. !! main.go:223: !! Use the -pools="" command line option to make the relay private. !! main.go:224: !!! pool.go:17: Joining LINK REMOVED, ONLY ONE LINK FOR NEW USERS pool.go:38: Failed to join https://relays.syncthing.net/endpoint due to an internal server error: test failed

Tried without an empty --status-srv as well but ends with the same error.

The relay pool server can’t establish a connection with your relay on port 22067.

I think -ext-address should just be a port? The pool server looks to see where the connection came from to see the ip of your relay, I think?

Otherwise, suspect your firewall.

1 Like

I had the same issue on an un-firewalled / not NATed server and forcing the listen address fixed the problem. Maybe there is some issue on the NAT detection.

Neither the relay nor the pool server care about NAT. The relay makes an outbound request to the pool server. The pool server makes a request back to the IP which made that first request on the relay’s port, or the port specified by -ext-address if given (to allow firewalls to do port redirection from 443 to something which an unprivileged relay can bind to, see the docs).

If that connection can’t be made, the test fails.

Relays aren’t intended to be run behind NAT - if you’ve got NAT, you’re probably on a home internet connection, which isn’t going to be good enough.

Hey folks! Thanks for such a quick answers. It was firewall issues, not quite comfortable with UFW in Ubuntu just yet… It all works fine now and hopefully should 1gbit/sec be better than nothing even for a home connection. :slight_smile:

Note that 1gbps up and down will total up to 5 million gigabits over the course of a month. Make sure you’re not going to be hit with a fine / throttle for exceeding your bandwidth cap!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.