Failed to exchange Hello messages with

sorry I am trying to find solution which I did describe here

but maybe I should ask here first :slight_smile:

I have syncthing on server in docker behind SWAG (I did tested that on separate raspberry and works ok) and looks that server is trying to connect client on different port as 22000.

strange thing is that firstly it did established connection and sync is working OK but I still getting those fail messages.


in connection config I have only “local discovery” enabled.

enabling “nat traversal” did not help there was a message

quic:// detected NAT type: Symmetric NAT
Detected 1 NAT service

but fail messages still coming

I would recommend to use networkmode host for your container.

yes but I have same configuration on testing raspeberry {well, at least I dont see difference} and there is not such problem

I delete container and remove config directory. Then I did start new container. I can access web gui and I see all default settings, so I enable only “local discovery”.

I am clicking “add remove device” and I can see all other devices which are running syncthing.

One is my laptop and another is my phone. {also my son and wife laptop}.

I did not add any device but already I can see fail message :

Failed to exchange Hello messages with QZA2RWM-xxxx 
write tcp> write: connection reset by peer

that is my laptop, strange …

  1. my laptop can connect with another syncthing devices.
  2. looks that problem is with discovery

ok I did pair my phone with server and it perfectly works. photos from phone are synced with just created new syncthing container on server.

There is only one fail message which I did past few line before. It is very strange, I have firewalld on laptop and syncthing is enabled. I did enable LOG denied

firewall-cmd --get-log-denied

but dont see anything in journal

there is also nothing strange in syncthing log on laptop

Just for the record, local discovery is broken on Android (which I assume the “phone” mentioned later runs). If you want it to connect automatically, you need to either enable global discovery and/or relaying, or hard-code the IP address (or hostname).

looks I did find a problem

on server I did replace syncthing from distro with syncthing from LSIO.container.

so new NODE is running on server.

on laptop I did keep old one and that was a source of “connection reset by peer” I guess.

I did turn on “connection” logging on laptop and there was a message for server IP “unexpected device id, expected XXX got YYY”.

Also in webgui, you need to click on device and in identification there was red message which I did overlook.

so I did remove old node on laptop and fail message on server stop.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.