Failed to exchange hello messages while using ddns?

Hi! I have syncthing on my main pc. I use it to also host a minecraft server (I use dynu ddns); I’m getting all the time this:

[VV3BK] 15:22:41 INFO: Failed to exchange Hello messages with OP3B6CY at 192.168.1.170:22000-XXX.XXX.XXX.XXX:YYYYY/tcp-server/TLS1.3-TLS_CHACHA20_POLY1305_SHA256: write tcp 192.168.1.170:22000->XXX.XXX.XXX.XXX:YYYYY: wsasend: An existing connection was forcibly closed by the remote host.

[VV3BK] 15:22:51 INFO: Failed to exchange Hello messages with XT3HB7I at [::]:22000-XXX.XXX.XXX.XXX:YYYYY/quic-server/TLS1.3-TLS_CHACHA20_POLY1305_SHA256: Application error 0x0: closing

[VV3BK] 15:23:16 INFO: Failed to exchange Hello messages with XT3HB7I at 192.168.1.170:22000-XXX.XXX.XXX.XXX:YYYYY/tcp-server/TLS1.3-TLS_CHACHA20_POLY1305_SHA256: write tcp 192.168.1.170:22000->XXX.XXX.XXX.XXX:YYYYY: wsasend: An existing connection was forcibly closed by the remote host.

[VV3BK] 15:23:16 INFO: Failed to exchange Hello messages with XT3HB7I at [::]:22000-XXX.XXX.XXX.XXX:YYYYY/quic-server/TLS1.3-TLS_CHACHA20_POLY1305_SHA256: Application error 0x0: closing

[VV3BK] 15:23:26 INFO: Failed to exchange Hello messages with XT3HB7I at 192.168.1.170:22000-XXX.XXX.XXX.XXX:YYYYY/tcp-server/TLS1.3-LS_CHACHA20_POLY1305_SHA256: write tcp 192.168.1.170:22000->XXX.XXX.XXX.XXX:YYYYY: wsasend: An existing connection was forcibly closed by the remote host.

[VV3BK] 15:23:31 INFO: Failed to exchange Hello messages with XT3HB7I at [::]:22000-XXX.XXX.XXX.XXX:YYYYY/quic-server/TLS1.3-TLS_CHACHA20_POLY1305_SHA256: Application error 0x0: closing

[VV3BK] 15:23:51 INFO: Failed to exchange Hello messages with XT3HB7I at [::]:22000-XXX.XXX.XXX.XXX:YYYYY/quic-server/TLS1.3-TLS_CHACHA20_POLY1305_SHA256: Application error 0x0: closing

[VV3BK] 15:23:51 INFO: Failed to exchange Hello messages with OP3B6CY at 92.168.1.170:22000-XXX.XXX.XXX.XXX:YYYYY/tcp-server/TLS1.3-LS_CHACHA20_POLY1305_SHA256: write tcp 192.168.1.170:22000->XXX.XXX.XXX.XXX:YYYYY: wsasend: An existing connection was forcibly closed by the remote host.

I also have a raspberry pi backup server (that also uses a ddns) but it doesn’t have any problem. I tried doing a fresh new install of windows 10 but nothing. I’m getting crazy! Turning of the firewall doesn’t help neither. :frowning:

Without a ddns it works… can you help me?

Look on the other side for why it closes the connection, probably.

On my raspy:

2021-09-17 15:34:11 Puller (folder “Mc Server” (zqwga-adoqo), item “world_nether/level.dat”): syncing: file modified but not rescanned; will try again later

2021-09-17 15:34:11 Puller (folder “Mc Server” (zqwga-adoqo), item “world_nether/DIM-1/region/r.-1.-1.mca”): syncing: file modified but not rescanned; will try again later

2021-09-17 15:34:11 Puller (folder “Mc Server” (zqwga-adoqo), item “world_the_end/level.dat_old”): syncing: file modified but not rescanned; will try again later

2021-09-17 15:34:11 Puller (folder “Mc Server” (zqwga-adoqo), item “world_nether/DIM-1/region/r.0.0.mca”): syncing: file modified but not rescanned; will try again later

2021-09-17 15:34:11 “Mc Server” (zqwga-adoqo): Failed to sync 16 items

2021-09-17 15:34:11 Folder “Mc Server” (zqwga-adoqo) isn’t making sync progress - retrying in 1m7s.

I don’t get any disconnection logs… :((

To be able to use DDNS, you should have the Internet, try to connect only through a relay.