Failed to create folder root directory mkdir /Drive_Share_Vol1: permission denied (on Syn DSM7)

First time trying to get Syncthing working and have been struggling and reading posts for last couple hours. I’m running DSM 7.1-42661 Update 4 I Want to sync 1 folder on the NAS that is within a Shared folder. On the NAS, my Syncthing is version (by André Colomb) that I downloaded from the Package Center Community. Sharing with an android v9 on an LG G7 ThinQ running Syncthing v1.20.4. The existing folder I want to share on the NAS is: /Drive_Share_Vol1/Docs/1KeepassX

I followed “Option 2 - Per folder access” from Permission Management · SynoCommunity/spksrc Wiki · GitHub Using File Station I granted sc-syncthing Traverse and list permissions in Drive_Share_Vol1 and also in Docs. I granted sc-syncthing Read & Write to the folder 1KeepassX. Both the NAS and my LG phone are setup as devices and appear to be setup correctly.

When adding the Folder in Syncthing on the NAS I use: Folder Label: 1KeepassX and folder path (copy and pasted from file station): /Drive_Share_Vol1/Docs/1KeepassX In the Sharing tab, I check the box next to my phone. I leave all other settings unchanged. When I hit save, it says the folder is Stopped and there are two Notices above: 2022-08-21 18:17:59: Failed to create folder root directory mkdir /Drive_Share_Vol1: permission denied 2022-08-21 18:17:59: Error on folder “1KeepassX” (xxxxx-xxxxx): folder path missing

I need some help. Apparently I’m missing a permission or not specifying the source folder correctly?

Hi there!

As for permissions, that can be a little tricky on DSM. Have you seen the dialog somewhere in the File Station app where you can check the effective permissions for a given path? Sorry I don’t know how to find it exactly from the top of my head, but I guess somewhere in the right-click menu. It’s called Permission Inspector or similar IIRC.

Regarding the path, that does look a little strange, I’ve only encountered things starting with /volume1/... or the like. Haven’t used DSM 7 yet though. You could try getting access through SSH to the NAS and see what paths are really there. The same should then work in Syncthing.

Best of luck, and let me know if you need more of a primer to SSH / terminal usage on DSM.

I would recommend to always put the group user “sc-syncthing” in the root directory and inherit it to the subfolders. That means shared subfolders in a volume such as /volume1/... so that /volume1/Drive_Share_Vol1/Docs/1KeepassX is included from the root and not only the subfolder /1KeepassX.

This can also be done via Filestation, but I always use Control Panel > Shared Folders. All shared folders which works with Syncthing get the group user in the inheritable permissions.

Maybe this will fix the problem.

In such issues there is no difference between DSM 6 and DSM 7

I didn’t even think about using SSH to get the true folder path. That solved it. As you suggested, I needed to add /volume1/… to my path spec and all worked fine. Thanks all. Andre I haven’t seen the ‘effective permissions’ function but I’ll be on the lookout for it. I have wrestled with permissions on a few occasions, and sounds like that should help greatly. Andy I also like the idea of putting group user sc-syncthing in the root and inherit it down. i will make that change next weekend. Again, thanks all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.