Extremely slow transfer speed?

Syncthing is amazing. It did everything I wanted easily.

But… the speed transfer in my setup is atrocious. I tested transfering 1 30MB pdf to only one other computer and I got a rate of 25 kib/s. In comparison, copying the file using teamviewer took about 1-2 seconds, everything else being the same.

My setup is a dozen computers connected with ethernet cables through a switch. I have little to no experience in this kind of structure, everything was in place beforehand. I believe the number of computers is not a factor, because my test was done with a folder in only 2 computers. The overall structure seems fine as well, because online transfer systems (google drive, teamviewer, dropbox…) are very fast.

Given my lack of knowledge, I would like directions where can I start troubleshooting.

Thank you!

There are plenty of threads on the forum explaining what to look at.

The first place to check would be if the transfer is, for whatever reason, going through a relay.

Yeah, I found out it was going through a relay, so I checked the documentation of why this would be happening… and my UPnP is already enabled, it even shows all the syncthing installations in the UPnP list.

I disabled the relay connection, disabled firewalls and antivirus on both ends, also tried pointing the exact port in the device address field on both ends. No luck. There’s always the chance I’m not seeing something simple, as I have no experience in this. I’ll have to try again tomorrow, still couldn’t find the issue.

Which st version do you use?

Syncthing v1.1.0 SyncTrayzor 1.1.22

A relevant observation might be that when I try to add a remote device, I can see their IDs in the list.

For future reference, I fixed all computers by following documentation, except for my notebook.

After trying everything I could possibly think of, in this specific computer, what worked was allowing Synctrayzor (on top of Syncthing) in the firewall on both ends. Probably some obscure case, as the other dozen computers didn’t need it, but that’s what worked for this particularly troublesome notebook.

Hello everyone! I have one problem like this. We uses Syncthinc for receiving every day backups from clients to our NAS. NAS works under Debian. Files is too large (10Gb-100Gb), and Syncthing is only possible chance to receive it. We use direct connection to our IP and all clients have static IP. But if I start syncing all 100 folders, receiving speed down to KBps and if I pause it all and start syncing 2-3 folders, I have ~100MBps. Did someone know the way to limit number of syncing folders at the same time?

I’m using the latest versions of Syncthing (1.1.1-RC-1) on a three laptops and RaspberryPI. All devices and folders are setup with default options. Syncs works as expected over LAN reaching 2-4Mbs but on WAN that drops to <7Kbs. This applies using mobile data or VDSL connections.

GUIs are showing that connections are through relay and TCP, but the speed would indicate relays only.

I have turned relay connection off and devices cannot connect. Turn on again and connection is within a minute, but speed is slow.

I think this only started recently, perhaps with ST 1.1.1

Have other experienced anything similar?

There’s only one connection active at a time and in your case it’s over relay, which can be slow. I am not aware of anything that changed recently in that regard. In general you need to troubleshoot firewalls: The one locally on your device where Syncthing is running and the one on your router (port forwards or UPnP/NAT-PMP). The problem could be discovery, but I’d guess it’s firewall - you can check the top right hand side of the web UI for discovery status.

Thanks for the quick response, Simon.

I have check that UPnP is enable on my router and that firewall setting have not changed. All OK.

The discovery on the PI is showing 4/5 (seems normal), the UFW firewall setting on the PI have not changed either. The connection address on the PI is currently dynamic.

The download rates is currently 12.5Kbs over mobile data.

I was thinking of rolling back to ST 1.0.1 but you seemed to have ruled that out.

I didn’t rule anything out, I just don’t expect it to help, which might be wrong :wink:

I’d check the firewall settings nonetheless as well as Syncthing logs for anything abnormal/related to connections.

You can’t and it’s not the cause. High CPU is in most cases because files are being hashed, which is not for encryption, it’s just due to the block based nature of syncthing.

Screenshot of UFW on PI

Screenshot of PI GUI

Extract from log on PI

2019-03-25 22:04:23 Device NMGSQSY-SZAFPAC-KXDJFPK-W5FINLE-7MCO6SL-XXUQ54H-WYM7TVS-ZVVEIQH client is "syncthing v1.1.0" named "Moto E (4)" at
2019-03-25 22:04:24 Failed to exchange Hello messages with NMGSQSY-SZAFPAC-KXDJFPK-W5FINLE-7MCO6SL-XXUQ54H-WYM7TVS-ZVVEIQH at [fe80::e1f0:92d:e0dd:f598%wlan0]:22000-[fe80::3a80:dfff:fe5c:871d%wlan0]:50244/tcp-server/TLS1.2-TLS_ECDHE_ECDSA_WITH_CHACHA20_POLY1305: EOF
2019-03-25 22:04:40 Connection to NMGSQSY-SZAFPAC-KXDJFPK-W5FINLE-7MCO6SL-XXUQ54H-WYM7TVS-ZVVEIQH at closed: reading length: read tcp> read: connection reset by peer
2019-03-25 22:08:51 Established secure connection to NMGSQSY-SZAFPAC-KXDJFPK-W5FINLE-7MCO6SL-XXUQ54H-WYM7TVS-ZVVEIQH at
2019-03-25 22:08:51 Device NMGSQSY-SZAFPAC-KXDJFPK-W5FINLE-7MCO6SL-XXUQ54H-WYM7TVS-ZVVEIQH client is "syncthing v1.1.0" named "Moto E (4)" at

Ok. So why receiving speed drops if CPU load is 100% ? But all goes good if I hold most clients on pause and syncing 2-3 clients. And next question: is it possible to add auto switch to pause if limit of syncing points is exceeded?

I have experimented with two laptops connected through LAN and then through WAN (mobile data). Both are running ST 1.1.1~RC2. Firewalls are identical: sudo ufw status verbose Status: active Logging: on (low) Default: deny (incoming), allow (outgoing), disabled (routed) New profiles: skip

To Action From

22 ALLOW IN Anywhere
22000/tcp (syncthing) ALLOW IN Anywhere
21027/udp (syncthing) ALLOW IN Anywhere
22 (v6) ALLOW IN Anywhere (v6)
22000/tcp (syncthing (v6)) ALLOW IN Anywhere (v6)
21027/udp (syncthing (v6)) ALLOW IN Anywhere (v6)

22 ALLOW OUT Anywhere
22 (v6) ALLOW OUT Anywhere (v6)

Connections are approx 2-3Mbps over LAN (TCP) and 6Kbps over WAN. WAN connection is via relay servers.

I then downgrade both side to ST 1.0.1 and the results were the same, with WAN connections again through relay.

WAN connections using mobile data or VDSL are always via relay.

Any suggestions?

After reenabling relays, and reestablishing connections, mouseover of ‘Address’ in GUI shows ‘relay-client TLS1.2…’

So what I missed and suspect to be the problem is “through WAN (mobile data)”. I think there have been issues with establishing direct connections on mobile data reported before and the (suspected?) reason was, that the mobile data provider essentially is an additional firewall and blocks these connections.

Thanks again Simon, but the issue also occurs with VDSL and ADSL2 connections.

I wonder if it has to do with recent updates to TSL?

I think I know what has caused this, and it was me using parental control DNS settings (OpenDNS) on a router connected using VDSL.

Thanks for your help, Simon.

I still wonder mobile data is slow, because that has been really useful to me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.