Extend Synology https certificates (DSM 7.x) to Syncthing

Hi there guys, I just got to know Syncthing and I absolutely fell in love with it. I managed to properly sync everything between my Synology NAS and my devices but there is something that puzzles me: the https certificates release via Letsencrypt for my NAS web GUI are not extended to the Syncthing GUI as well.

I have found a guide for doing this “extension” here but it does not seem to be working for DSM 7.x (the folders at which the script is pointing are not present in the the system folders).

Do you have any suggestion on how to proceed?

Actually this have nothing to do with each other. It is as described in the linlked post. From this point of view, each application must be set up separately. Although that should be independent of the DSM version, I am not aware that there is a difference between DSM 6 and DSM 7 at this point.

Hi Andy, sorry for the mistake in the problem introduction.

At the moment, with DSM 7.x, I was able to find the Synology certificates (although there are 4 files, RSA cert+privkey and ECC cert+privkey, not described in the posted guide) but I can’t find anywhere the Syncthing certificates (/usr/local/syncthing/ folder does not exist, and I assume that the DSM 7.x uses a different default folder?)

Any suggestions?

I think you use the only one on DSM 7 running package of SynoCommunity from Safihre, than this itmes you find


In difference to DSM 6 you will find in DSM 7 more then one APP related folder inside of the volume root


I’m currently working on the SynoCommunity package to get integrated with the DSM user interface for “Certificate Management”. It no longer works for DSM 7.0 however, because Synology decided to limit the API to only their own packages. See the PR at framework, syncthing: Implement DSM managed certificate for services (fixes #3436) by acolomb · Pull Request #4930 · SynoCommunity/spksrc · GitHub.

So for DSM 7 you currently only have the option to copy the certificates manually. I’ve posted a script to do that in another topic because the old one was locked.

Sorry for not replying sooner, I seem to have missed a lot of notifications from Discourse lately.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.