Error when trying to delete or add device

I’m trying to delete a device on Mac OS X using 0.11.7 and every time I try to delete a device I get "Syncthing seems to be experiencing a problem processing your request. Please refresh the page or restart Syncthing if the problem persists."

I restart, shutdown and restart but yet still am having trouble getting past this problem. Any thoughts?

Is your browser denying cookies?

No, I’ve also tried this on three different browsers and am constantly getting this error message.

The error is coming up even if I try to delete my default shared folder or if I try to add a new shared folder.

I’ve also tried deleting the Application Preferences/Synthing folder to see if it was a settings issue, but the problem persists.

Are you using a proxy of some sorts, or ssh tunnelling?

I sometimes use a VPN but I have tried with and without the VPN.

I restarted my computer and it seems to be working now. I’ll update this thread if the problem occurs again.

Did you open 2 GUIs of 2 syncthings in one browser at the same time? I remember seeing something like this on the issue server once…

This is very well possible because I was testing various browsers testing to see what the problem was.

Edit: Also now whne I quit my terminal it always says “Are you sure you want to exit Syncthing (2)”. So this is a potential problem.

This all started because my VPS was having trouble and I was trying to diagnose it.

The Syncthing GUI uses cookies to maintain a session. You can’t have more than one session open against the same website in the same browser, much like you can’t log in as two different users on this forum at the same time from the same browser, so that may cause this issue.

I also sometimes get this problem in Firefox but the easy way to fix it is just to hit Ctrl+F5 (Refresh Page & Cache)

maybe config not writable?

99% of the cases of this issue are:

  1. Using some sort of proxy/SSH tunneling which causes the cookies to be issued under an incorrect domain causing the browser to refuse them.
  2. Having some privacy add-on enabled in the browser causing cookies to be refused.
  3. Browser failing to provide the initially provided Basic Auth header to re-authenticate given syncthing was restarted and the session cookie is no longer valid (refreshing the page usually fixes this)
  4. Having multiple sessions for the same site (as calmh already explained)
1 Like