Error: Class not registered


My files are not updating on running syncthing.exe and on running the exe initially it gives an error " class not registered "

Can you please help.

Syncthing doesn’t have classes nor that error message, so I suspect the error you are seeing is from something else and there is something wrong with your installation.

Could it be that auto start browser is set and on your OS http is not registered by any software for some reason. I think I saw http and the like called classes, which are to be registered by software, in contrast to file types / extensions for files.

1 Like

Thanks for your reply.

I have tried uninstalling and reinstalling the package but its still giving me the same error.The files are getting updated at the server but its not getting updated at my end from the server.This error comes as soon as we execute the exe.

On accessing it shows that the folders are updated but I am unable to find the issue. Please help

The error just says that no application in your operating system is registered to handle http urls. You can disable starting the browser in advanced options and the error will go away.

The fact that something is not syncing is possibly because you haven’t shared the folder, shared it at the wrong path, or shared the wrong id

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.