Encryption - nothing being synced

I have an existing share between multiple devices which works fine. I have introduced a new device, which so far I have only added to one of my existing devices and set it to untrusted. I have shared an existing share with this device and given it a password. The untrusted device popped the usual dialogue box and I accepted the share. I can see it shows as “Receive Encrypted”. Straight away, the share went into an “Up to Date” state with 0 directories and files. Sure enough, checking the directory show it is empty and not filled with encrypted files. From the sending device, I note it has a 1 next to the name of the remote device and says “The remote device has not accepted sharing this folder”.

Any ideas what I am doing wrong?

All devices use v1.27.6. This particular remote device is a Pi Zero (armhf). I previously synced unencrypted data to this device with no issues but wanted to encrypt this data. I removed all existing shares, then devices so by the end, it was looking like it was at its deafult config. To ensure this, I stopped the syncthing service, moved my existing config from ~/.local/state to another directory and restarted the service to start a fresh.

Screenshot 2024-04-29 123332

I’ve seen this happen quite regularly too when it comes to receive-encrypted folders. Usually it gets resolved by manually pausing and resuming the folder. It’s worth a shot.

If that doesn’t help, then there may be clues in the logs.

1 Like

Wow. It worked. Thanks!

I tried pausing the remote end first, but that didn’t seem to make any difference. Pausing and restarting the sending end seemed to kick it into life.

1 Like

Just to say. I have a number of folders to share, and so far each one of them has had to be paused/resumed on the sending end for files to synchronise.


I’ve configured my receiving device to auto accept shares from this particular sending device, and now it works without needing to pause/resume.


I am still seeing the issue. Auto Accept does help, but I have still had new folder shares where I need to pause/resume.