Download/Update stay at 0 or really low


I have some files that I synchrise from my computer (Linux) to my Android. Everything was fine, until one day the status of the syncrhonised went to 0. Most of my files are still syncronised, but not all of them. If I add new files they also seem to be synchronised, however I still get the status that nothing is being synchronized. It looks like this…

Also the download/upload rates stay by 0 bps. What can I do?

unknown-dev,Linux(64 bit) :man_shrugging:

Just to elaborate, this usually means that you’re using a version of Syncthing from your OS repository, which is also very likely to be heavily outdated. If you’re on Debian/Ubuntu, please check and follow the steps. If not, then please provide more information what kind of OS you’re using and how you’ve installed Syncthing in the first place.

Thanks for the answer. I performed the update, however the problem persists. It now looks like this:

My OS is: NAME=“Linux Mint” VERSION=“20.3 (Una)” ID=linuxmint ID_LIKE=ubuntu PRETTY_NAME=“Linux Mint 20.3”

And the Syncthing version: ~$ Syncthing --version: Syncthing v1.19.2-rc.2 “Fermium Flea” (go1.17.7 linux-amd64) 2022-03-21 03:47:47 UTC [noupgrade]

I think we need to see what the situation looks like on the Android device. Please open the Web GUI (using the left slide-out menu) and check what exactly is going on there. Screenshots are always welcome too.

Here you go =)

Hmm, so it does seem the folders with the files are indeed present on Android, yet they are also marked as “Out Of Sync”…

Before doing anything else, does checking “ignore permissions” in the folder settings on both sides make any difference?

Hi, Unfortunately it did nothing =(

Hi, Do you suggest any further steps?

At this point I’d recommend to try removing the folders in Syncthing on Android, and then re-adding them. This should only result in Syncthing re-indexing the already existing files without re-downloading them, but the persistent errors should go away.

Hi thanks. Still not working. Could it be some firewall problem?

The weird part is also the Upload/Download rates. They stay in 0, and for a brief second, after pausing and resuming, the rates raise just a bit, and then back to 0. That is why this is rather a network configuration problem with the client.

I’m not sure, but judging by the fact that they do connect with one another, I’d personally assume that something else is the culprit here. The transfer rates may be low, but it appears that the global states on both sides are almost identical, which would indicate that the files themselves have already been synced despite the “out of sync” errors. In other words, if there’s nothing to sync, it is normal for the download and upload rates to stay very low.

If removing and re-adding the folders hasn’t helped, then I’d like to ask you to provide more detailed information and logs as follows.

  1. Post screenshots showing the Syncthing Web GUI on all affected devices. If possible, include the out of sync items in the screenshots.
  2. Go to “Actions → Advanced → GUI” and enable “Debugging”.
  3. Go to “Actions” and click “Support Bundle”. A debug archive will be downloaded.
  4. Repeat the steps on each device, then upload all the archives here.

Ok, now by just letting it idle, suddenly everything was synchronized. Apparently the trick you mentioned of deleting and adding the directories helped.

I appreciate your help and fast responses.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.