Docket Syncthing will not mkdir.... I made one manually on the boot drive and it syncs

Docket Syncthing will not mkdir… I made on manually on the boot drive and it syncs but I cannot see my Raid drives at all from Syncthing. It kept on telling me it couldn’t make a directory so I did all the manual Chmod and made directories but it was actually because it could not get to the raid drive. How do I point Syncthing to a raid drive. Not a big linus person so kinda dumb about this.

Docker doesn’t see the hard-drives your machine has unless you explicitly mount them. Docker documentation explains how to mount a volume.

Also, it’s not clear what you mean “cannot see”, because syncthing doesn’t have a browser, you just type in the volume path and that’s it.

Cannot see: When I tried to pick the path it was not available. Weird thing is I am trying to figure out where it put the folder I shared from my Raspberry Pi. The Raspberry Pi was so much easier than the docker installation. Don’t get me wrong, the install went without a hitch. Sharing folder is the big problem in the docker version. The sharing on the Pi was a cinch. I am using many of these same folders from the OMV server to other Docker instances like Plex and so on. Syncthing is much more complicated to get my shares. I actually shared all of these folders and Syncthing still does not see them. OMV shared, changed all the rights with the chmod 777, all the folders are shared with everyone and allows guests, also did a SMB share with all of these also.

Sorry, but I still don’t understand what you mean by “see them”. See what, where?

If you are running in docker, did you mount the folders as docker volumes?

OH hmmm you mean when I created the Docker Stack for Syncthing ? No I did not… I only created the Config and Data1 and Data2… but if I have to do that, that sound like I can’t create folders on the fly to sync! Is that the case that I would have to create everything from the beginning? All of my Raid volumes are shared in OMV and also shared as SMB. I can map them from my Windows 10 PC so I know they are working.

Yup mapped it in the Stack and seems to be working … Can I point frile from one folder on a server to another folder on the destination server ?

Sorry but I have no idea what you are talking about.

Never mind I think I figured it out…

Syncthing Question

I have Open Media Vault running Docker and would like to sync two folders with another server.

I created a user syncthing in Open Media Vault and created a folder /srv/dev-disk-by-label-Mediabak/Sync/movies and gave the syncthing user Read/Write rights to the folder. When I add this folder to syncthing I get a warning :

2020-11-24 19:38:22: Failed to create folder root directory mkdir /srv/dev-disk-by-label-Mediabak: permission denied

2020-11-24 19:38:22: Error on folder “movies” (o9eax-d5zsx): folder path missing.

The movies folder is “Stopped”

Folder ID o9eax-d5zsx

Folder Path /srv/dev-disk-by-label-Mediabak/Sync/movies /srv/dev-disk-by-label-Mediabak/Sync/movies

Error folder path missing

Global State 0 0 ~0 B

Local State 0 0 ~0 B

Rescans 1h Enabled

Shared With

I have tried to solve this problem for about a week now, on and off.

So the question is :

  1. Failed to create folder root directory mkdir where the heck is it trying to create this folder?
  2. how do I know if it is actually going to the folder I am pointing it at or is it trying to make a new one ?

Both of these are really Docker-on-Open Media Vault questions. Syncthing is just doing its thing in the environment it’s launched in, the rest is a question of how that is mapped to the outside world by Docker, etc.

OK I see … It is frustrating because I am so close and I got the two server to sync and I see what looks like it is working OK. I thought I did this by putting the actual folder path in the Actions -> Settings -> Default Folder Path, however when I looked at it this morning that setting is blank, yet it still says the two folders are up to date with nothing in them. Is there a way to figure out what folder that the Folder ID 6yxty-zwqam signifies? I mean, can I actually trace this back to an actual path somehow and see if it is the correct one?

You are trying to sync folder /srv/dev-disk-by-label-Mediabak/Sync/movies in your host (OMV) which is outside your Syncthing Docker container, did I get this right?

If so, it looks like you need to look up the Docker documentation on how to use Bind Mount.

I’m new to Docker and Syncthing too, but my understanding is that Docker uses Bind Mount for storing data anywhere on the host system, but the Syncthing Docker container defaults to using a specific part of the host filesystem which is managed by Docker - called Volumes - to store data.

For example, my Syncthing on Docker setup sees the Synthing home folder as /var/syncthing/ but the actual physical location of this folder on the host system is /var/lib/docker/volumes/volume_name/_data/.

If I then try to use my NAS public folder as Syncthing shared folder without first "bind mount"ing that folder, I get the permission denied message. So you could either continue to hold your data in /srv/dev-disk-by-label-Mediabak/Sync/movies and bind mount the folder when you run Syncthing, or move the data into your Syncthing Docker volume.

thanks I will do some searching on bind mounting … thanks for the help… I think this Syncthing is a great idea but so far it is not easy to use.

happy to help in every little way… Syncthing is awesome. My NAS doesn’t offer a “native” Syncthing app and also restricts installation of third-party apps which meant I had to do the Docker route. This addition of Docker to the mix and my very little knowledge of how it works is what has complicated my Syncthing installation. It was very easy to set up on my Android phone and Linux laptop as “native” app.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.