Docker Image Not Removing Hidden Flag

Hello, I searched the forum and the Github issues and haven’t found a match so here goes nothing:

I am currently playing with the Docker image on a Debian server with the config and the folders saved remotely to a nas. Everything works fine transferring to/from my Mac, Android, and share point on my nas EXCEPT: any file that is downloaded by the Docker image becomes hidden on the nas. I can put files on the nas and it will spread fine, and keep its visibility on all devices; but if Docker downloads a file, it gains the hidden flag.

Here is my Docker run command if it helps:

sudo docker run
–restart unless-stopped
-v /home/fox/nasDocker/syncthing:/var/syncthing
-v /home/fox/nasRoot/archives/syncthingDumps:/var/syncthingDumps
-e PGID=1000
-e PUID=1000


This is Docker on Debian, and Linux doesn’t have a hidden flag…? Is the NAS a Windows box with an SMB mount from the Debian box? Or something else and things look hidden from Windows clients looking at the NAS? Even so, Syncthing on Linux (Docker) doesn’t (and can’t) set a hidden flag, so not sure where it would come from. Perhaps some default ACL on the NAS that is getting inherited? Some magic the NAS does to set a “hidden” flag on dotfiles that doesn’t get cleared on rename? :man_shrugging:

Interesting. Thank you I will start down that rabbit hole.

I should have been more clear after a re-read :sweat_smile:. I am using Docker on Debian to write to Freenas. I have that share mounted on my Mac. Having a shared folder between my Android phone, Docker, and a separate one on my Mac, the NAS point always marks downloaded files hidden according to my Mac. I just assumed it was Syncthing because I’ve never seen this happen before.

I have no idea how that works, FreeNAS seems to have an odd ACL system by default.

Generally speaking you will usually suffer less pains if you run Syncthing on the actual machine where the files are stored. That way fewer things are lost in translation between what Syncthing does and what actually happens on disk.

I actually found the issue!

It was right where you said it’d be. Not sure if anyone else will ever have this issue but:

Freenas with an SMB share attempts to mirror the Hidden flag because of the ‘.filename’

The advanced mode of the Freenas SMB share settings has a ‘Show Hidden Files’ toggle:

“Set to disable the Windows hidden attribute on a new Unix hidden file. Unix hidden filenames start with a dot: .foo . Existing files are not affected.”

Flipped that bad boy on and its been working fine.

Thank you for the help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.