discovery dns queries but discovery is not enabled

Hi.

I have been using syncthing quite successfully for about a year. Thanks for all the hard work. On all my machines all four boxes are unticked in the connections setting.

I have noticed that my raspberry pi - running v1.17.0, Linux (32-bit ARM) - is contacting V4 and V6 discovery addresses every 5 minutes. The problem was also apparent on earlier versions.

I have searched for a solution but all suggest to turn off global discovery which is already disabled.

Any help appreciated.

1 Like

I don’t know. My Syncthing doesn’t do this when configured like that; it’s not supposed to, and I just confirmed it by looking at tcpdump for five minutes.

@calmh are you using raspberry pi OS ?

The pi I am using is still on stretch. Not sure if that makes a difference.

Here is an example from my pihole DNS

021-06-06 07:51:16 A discovery-v6.syncthing.net pi.local OK (cached) NODATA (0.1ms) Blacklist
2021-06-06 07:49:05 A discovery-v4.syncthing.net pi.local OK (forwarded to x.x.x.x#53) IP (16.3ms)

Double check in the config that global discovery really is disabled. Also double check that you are looking at the correct config (possibly modified through --home/--config command line flags, or check through web UI). Then check in logs if there are any lines containing “discovery” and post them, together with the first line (just to be sure about what build exactly you are running).

@imsodin Thanks for the reply. I checked all those things and everything seemed OK. So I rebooted the Pi with setting unchanged and that seems to have fixed the issue. No more DNS queries since reboot. I should of course have tried that first off. I will keep an eye on the situation.