Disconnected devices between Pixel and Samsung

I have tried to connect Google Pixel and Samsung phone under a network. However, both phones cannot connect with each other. Actually, they can find each other when adding remote devices, and show up to date for once, then disconnected. At the same time, the announce server showed 0/2. I’ve tried below:

  • restart the service
  • restart the phone
  • uninstall and reinstall the app
  • untick the “global discovery” option

Both of phones have the latest Syncthing version from Play Store(v1.23.7).

Firstly, on both sides, please re-enable all the default options. This includes global and local discovery, relaying, and NAT traversal. Then, please open the Web GUI (using the left slide-out menu) and take a screenshot of what you see under “This Device”. The interesting part is “Discovery” and “Listeners”. You can also click on the numbers next to them and take a screenshot of the pop-up window.

Dear tomas86, thanks for your help. please see screenshoot of my Pixel as attached(Samsung showed the same discovery failure information).

update: I’ve exited other sync servcies and proxy services, the Discovery showed as attached. The port 21027 no longer occupied, folders show as “up to date”, but devices disconnected with each other and cannot communicate.

On the basis on the last two screenshots, the devices should theoretically be able to find each other and connect now. Are there any other obstructions in place, e.g. a firewall or network isolation enabled on the router side?

hi Tomas, thanks for your help. I change the Ip address from dynamic to stable and got the last two screenshots, the devices are connected but cannot communicate to each other. I don’t think any firewall or network isolation exists on the router side. No idea how to fix it…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.