Disagreement about what constitutes "Up To Date"

so, I have two servers running Syncthing. the main (Betelgeuse) runs Unraid and is in send-only mode, the secondary (Bellatrix) runs TrueNAS, and is receive-only.

everything worked swimmingly once I got it set up, but now I have an issue. Bellatrix reports all shares are synced. Betelgeuse disagrees, with a discrepancy of 3.7TB. I’ve tried rescanning from both ends, but that hasn’t made a difference. most confusing, it has been catching recent changes to that folder.

I’m sure I’m missing something obvious, but this has me stumped.

It looks like some index information went missing along the way. I’ve seen that happen (here, on the forum) but never narrowed down a cause. There’s no trivial fix. Running once with --reset-deltas on either side will force a re-transmission which may/could/should fix it. If it doesn’t, it’s more interesting…

1 Like

does “Send Full Index On Upgrade” in the advanced settings accomplish the same thing? I set that option on both, then restarted their respective containers. unfortunately, it didn’t help.

That should have the same effect, yes. Fascinating.

Please keep in mind that this setting only applies on actual upgrade (or a version change specifically). Just restarting Syncthing without changing the version doesn’t trigger a new index exchange.

I wondered about that. in the words of Terry Pratchett: “well that’s a bit of an embuggerance”. the TrueNAS container rarely updates, and I installed an update to the Unraid container almost immediately before creating my account here. looks like I’m in for a wait

[EDIT] of course, immediately after posting that, I tried updating the TrueNAS container, and it both updated, and rescanned the whole share. it is now aware that it was 3.7TB out of sync, and is correcting that.[/EDIT]

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.