Disabling auto startup in ChromeOS Linux

I am running syncthing v1.23.2 “Fermium Flea” (go1.20.1 linux-amd64) deb@build.syncthing.net 2023-02-27 03:45:16 UTC [noupgrade] in the default Linux provided on ChromeOS.

It works great. I just want to stop the automatic startup.

I tried sudo systemctl disable syncthing@<my_username>.service. This command runs without error, but on rebooting Syncthing still auto starts.


ChromeOS is not something I work with, but it may be worth looking at whether it still runs as @[your-username]; systemctl --type=service | grep syncthing.

Make sure you disabled the right service here:)

Then check the status of it systemctl status syncthing.service or systemctl status syncthing@[...].service

That should give you at least the point from where it was loaded; Loaded: loaded (/lib/systemd/system/.... Worst case you can remove that symlink manually.

And if you properly disabled it and it still auto starts, you can check if there are any dependencies that may trigger syncthing to be fired up; systemctl list-dependencies. In that case fix that or mask Syncthing’s service.

1 Like

Have you also checked systemctl --user status syncthing.service? There are two systemd ways to start services for a specific user - user or system service.

systemctl --user status syncthing.service ● syncthing.service - Syncthing - Open Source Continuous File Synchronization Loaded: loaded (/usr/lib/systemd/user/syncthing.service; enabled; vendor preset: enabled) Active: active (running) since Wed 2023-03-22 06:17:16 EDT; 17min ago

Hope this helps.

systemctl --type=service | grep syncthing Doesn’t error, or return anything.

systemctl status syncthing service Unit syncthing.service could not be found. Unit service.service could not be found.

systemctl status syncthing@.service ● syncthing@.service - Syncthing - Open Source Continuous File Synchronization for Loaded: loaded (/lib/systemd/system/syncthing@.service; disabled; vendor preset: enabled) Drop-In: /run/systemd/system/service.d └─zzz-lxc-service.conf Active: inactive (dead) Docs: man:syncthing(1)

Hope that helps.

Well apparently you do have it setup as a user service unit. To disable, use the same commands, but always with the --user option and without sudo. You might want to read up on the general distinction between system and user services in systemd.

See also Starting Syncthing Automatically — Syncthing documentation

systemctl --user disable syncthing.service Removed /home//.config/systemd/user/default.target.wants/syncthing.service.

This worked! Syncthing didn’t restart! Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.