Disable root instance from starting

I installed Syncthing and it runs as “root”. I added a service for it to run as “myuser” and that works fine, but the original “root” instance is also running and I can’t find a way to stop it permanently. (I can kill its processes manually but upon reboot it returns.) I’m on Linux Mint 19.3. Thanks!

None of “our” packagings start Syncthing automatically as any user, so either I’m not sure what you’re running or you need to disable it in the opposite way of how you enabled it…

I installed it via a curl procedure I found online. (curl -s https://syncthing.net/release-key.txt)

Once installed, I typed “syncthing” into terminal and it started. When I run top, it shows it’s running as root. It’s v1.5.0

If you don’t know how I can disable the “root” instance that’s OK, maybe someone else here will know how.


Just kill the processes, this will be the instance you launched by running the syncthing command.

I do but want a permanent solution.

I’m not sure, our packaging does not start it as root on startup, so you have to figure out what does that. Perhaps ps auxwwf shows which parent processes started it, and then you can follow the trail that way.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.