Devices remain disconnected

I’ve searched the forum and found some discussion on a few vaguely similar issues, but nothing specifically for my problem.

I have two devices, a ReadyNAS and a Windows 10 computer. The device info is as follows:

ReadyNAS => \\BACKUP [v1.18.1, Linux (32-bit ARM)]
Win10 => \\C52893-F [v1.22.2, Windows (64-bit Intel/AMD)]

They’re both on the same LAN.

Here’s the remote device list from \\BACKUP:

…and here’s the list from \\C52893-F:


I’ve verified that the Device IDs are correct in both directions.

What else do I need to do so that these two can see each other?

Could you also post screenshots of the expanded “Folders” panels on both the ReadyNas and Windows 10 machines?

According to the ReadyNAS, the Windows 10 machine is using a Syncthing relay so local discovery didn’t work for some reason. Is the Windows 10 device on a wireless connection while the ReadyNAS is wired? Is the Windows 10 or ReadyNAS got a firewall enabled?

Certainly, here you go…



\\C52893-F (Win10)

Is the Windows 10 device on a wireless connection while the ReadyNAS is wired?

No, they’re both wired. Plugged in to a simple 8-port switch.

Is the Windows 10 or ReadyNAS got a firewall enabled?

Win10 does for sure, and I assume ReadyNAS does as well. But I’m thinking that shouldn’t make a difference, since these are both outgoing connections. For example, Win10 to my Android phone (on WiFi) works just fine.

I’ve tried removing both devices from each other’s config and re-adding them, but they still fail to see each other.

This sure is odd…

Can you post full screenshots of the full Web GUI from all sides (including folders, this device, remote devices, etc.)?

That’s great. Best way to start because it keeps the network configuration simple.

Technically speaking, software such as Syncthing that provide a network service requires the ability to receive inbound connections (Syncthing is both a server and a client).

So to work around requiring users to punch holes in their firewall(s), a NAT traversal technique is used where two peers – e.g., your ReadyNAS and Windows 10 machine – first connect to an internet accessible server. The internet server then helps the two peers exchange their respective public IP addresses (as provided by the ISPs).


At least one issue I see is that for the “ReadyNAS” folder, its folder ID is “default” and it’s being shared with device C52893-F. However, in the screenshots from device C52893-F, there’s no matching folder ID. There’s only device fvaw5-4pis6 and 9c57d-fnstx. In order to sync a folder, its folder ID must match on every peer device.

I’m not sure what had gone wrong, but I reinstalled and rebooted on \\BACKUP, and everything synced right up as expected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.