Devices Appear "Disconnected" After Changing Router

I changed my router recently, now Syncthing on my Androidphone and on my Windows PC both appear to be disconnected from one another.

I really don’t have any more info than that, I’m looking at the console on SyncTrayzor on my PC and it shows Device XXXXXYY is android phone at [dynamic] with no errors at all, so I’m not sure how to identify what the cause of the problem is.

I do know that both devices have one another set to “dynamic” address, NAT traversal and Local Discovery are enabled, Global Discovery and relaying are disabled. Everything worked fine with these settings before replacing my router.

What should I check?

Local discovery is broken on newer versions of Android, so you need to enable at least global discovery for the two devices to be able to connect. Please also make sure that the network connection in Windows is set to “private” (see https://support.microsoft.com/windows/make-a-wi-fi-network-public-or-private-in-windows-0460117d-8d3e-a7ac-f003-7a0da607448d), as otherwise it won’t accept direct connections (forcing Syncthing to use relays which you’ve disabled).

That seems to have done the trick, thank you.

This makes me wonder what “global discovery” even means. Does this just mean that devices given the address of another device can find each other over the internet as opposed to a local network? I turned it off assuming that it would allow other people to see my device.

1 Like

It uses an internet service to exchange information about IP numbers to connect to, so the devices can find each other when direct, local broadcasts aren’t working or sufficient.

1 Like

The connection itself would still be local, right? I very specifically do not want to sync over the internet.

If possible, yes, you can look at the addresses to verify.