Device disconnected on android

First great work for this piece of software.

I have been using it without problem between some devices Win7-Win8-Linux I even succeed to make it work on IOS with and app called : fsync()

My problem is with Android, I didn’t succeed to make it work on Android so far, I am using the app made by Felix Ableitner and also tested the Silk App, same issue.

The working devices (Win7-Win8-Linux-IOS) are always displayed as “Disconnected” on the android device. The android device last seen status on the server is always : “never”

I can ping the android device. I can even access the web_GUI instance that is running on the android device over http or https.

Port forwarding and firewall have been setup.

It seems that UPnP is not working for the android device, how can I connect to this device? Any help will be much appreciated, anyone has encountered the same issue?

Here is the log from my android device:

--------beginning of /dev/log/main

--------beginning of /dev/log/system

16:28:47 INFO: syncthing v0.11.13 (go1.4.2 linux-arm android) 2015-07-05 17:44:55 UTC

16:28:47 INFO: My ID: bla.bla.bla-XXXXXXX-GUDEW89-D8OP5QA-WB2N5FO

16:28:47 INFO: Database block cache capacity 8192 KiB

16:28:47 INFO: OK: Ready to synchronize thefolder (read-write)

16:28:47 INFO: Completed initial scan (rw) of folder my-folder-cloud

16:28:47 INFO: Starting web GUI on

16:28:56 INFO: Starting local discover announcements

16:28:57 INFO: API listening on [::]:8080

the other devices are using Syncthing v0.11.20 - Android is using v0.11.13 on Android 4.2.2 Jelly Bean

I tested with Syncthing v0.11.13 on all the others devices and same issue.

Check if you can access syncthing protocol on android from another device.

Hi Audrius,

What command can I use on windows to check if I can access the syncthing protocol on the android device?

If I am correct Syncthing on the android devise is not listening on the port specified.

It is setup as follow on Android: Sync Protocol Listen Addresses

but it seeems that this connection never starts ??

Syncthing connections listed on the Android :

Yeah, from what you are showing it seems true, but I am not sure how accurate the tool you are using is.

If you have openssl installed, you can just do openssl s_client -host ipaddress -port expectedprot

Do you have some firewall thing on the phone perhaps?

There is no firewall activated on the phone. I also tested with one and leaving all ports open with iptable> same problem.

I am not using openssl.

I also just notice: On the PC side I have : INFO: Local discovery over IPv6 unavailable

Can this be the cause of the issue? Is there any way to debug the Android App to check if everything is working properly?

You can use openssl to verify port open’ness. No, v6 and local discovery has nothing todo with this, unless you’re on a v6 only network. I am not sure what the cause can be. I don’t want to believe syncthing is failing to listen on the right port, hence I’d check if it really isn’t listening via openssl.

so if I check the port used by the webgui running on the android machine 8080, I have an handshake with openssl.

When testing the Syncthing port of the android device: Sync Protocol Listen Adresses port 22000

I have :

$ openssl s_client -host MyLocalAndroidIP -port 22000

connect: Connection refused


and when testing the same 22000 port where it’s running correctly on another PC running Syncthing, I have an handshake with openssl.

Can you verify that it’s actually listening on 22000, by checking the settings in the web ui? I can’t think of why it would not start listening, apart from some sort of OS magic refusing it to do that.

yes it is setup on the port 22000 on the Android machine. I even tried to specify my local IP’s on both devices, still not working…


Having the same problem. Any solution?

Does this application require a rooted phone. It worked when phone was rooted. Will not work now that the phone is not rooted.

No it doesn’t. Check the required firewall settings in the docs.

Appreciate the response.

I did, but to no avail OR my firewall fu simply sucks. Are there other discussions available for this issue?

I see this on the desktop version: Invalid IGD response: invalid device UUID upnp-InternetGatewayDevice-1_0-001dce2991e5 (continuing anyway)

so indeed there is a network problem…

There are plenty of discussions, just search the forum. If you setup port forwarding correctly, you would not need UPnP.