Device disconnected - maybe locked out relays?


(Martin) #1

Hi,

I’ve been running syncthing for a while now on a NAS (Asustor), a PC (Linux Manjaro) and a netbook (also Linux Manjaro). The netbook and the NAS are connected to the same router, so that’s one network. But I have not set them up to sync. The PC is connected to a different router in a different network, and I have synced with both the netbook and the NAS. Since the NAS is supposed to act as a kind of backup, it has to copy all the data from the PC, which is roughly 5.5 mio files and 2.3 TB data. It took already about a week, when all of a sudden the NAS was reported not to be connected to the PC. However, the PC could connect to the netbook, which makes me rule out a router problem. I thought it over what I could have done, and remember only one thing that I did on the NAS: since there were a number of illegal attempts to log in to the NAS via ssh, I checked the list of IP adresses which tried to log in and put them all on a black list. Now I wonder if I mistakenly took one or more IP-address(es) which belong(s) to the syncthing relays, thus making it difficult or impossible for the two to connect any longer. Would this be a possible szenario? I’m not eager to go through the list of IP-addresses, it would take a lot of time. So first I would like to know if this is a possibility. If not, I am of course open for alternative suggestions. One more thing: When I ran STTRACE=discover syncthing I get the following (among others which do not seem to be serious porblems):

[5STJK] 2017/07/08 15:06:12.716990 global.go:147: DEBUG: globalClient.Lookup https://discovery-v4-2.syncthing.net/v2/?device=... 404 Not Found 
[5STJK] 2017/07/08 15:06:13.111165 global.go:147: DEBUG: globalClient.Lookup https://discovery-v4-3.syncthing.net/v2/?device=... 404 Not Found 
[5STJK] 2017/07/08 15:06:13.184057 global.go:147: DEBUG: globalClient.Lookup https://discovery-v4-4.syncthing.net/v2/?device=... 404 Not Found 
[5STJK] 2017/07/08 15:06:13.236365 global.go:142: DEBUG: globalClient.Lookup https://discovery-v6-2.syncthing.net/v2/?device=... Get https://discovery-v6-2.syncthing.net/v2/?device=...: dial tcp [2604:a880:800:10::182:a001]:443: connect: network is unreachable

(I replaced the device-ID with “…”) Does the above give any clue?


(Audrius Butkevicius) #2

This just implies that the other device hasn’t advertised its location hence cannot be found. You should verify that that device that you cannot connect to is able to connect to discovery servers and relays. Search the forum, I think there are a ton of threads explaining how to do that.


#3

This means, that you already have port forwarding to the NAS in place. Why don’t you forward the Syncthing port, so you don’t need relay servers.

And as you seem to be connecting to the NAS from outside your LAN (as you have SSH forwarded), you are probably already using dynamic DNS. So you can just add your DNS name with the port (like tcp://yourdnsname:22000 to the addresses field of the remote device (NAS) on your PC. No need for discovery servers then either.


(Martin) #4

Thanks for the replies. After a restart of the NAS, it works again. I wonder why it didn’t work when I restarted Syncthing from the GUI?

Thanks for that suggestion. However, what about the netbook then? Won’t it be excluded? I read the help but can’t really figure out how to add one address and then make it search for the netbook, because for that I don’t have a dynamic DNS.


#5

While your netbook is connected to the same router, you have dynamic DNS for it. Just set Syncthing to listen to another port than the default 22000 and put that in the addresses field for the remote device on your PC.


(Martin) #6

Ok, thanks, did that, but it didn’t really help (I think). I have repeated disconnects, and then the relays are shown again. I wonder if it’s because syncthing is causing too much load on the NAS and is unable to connect to the peer station, even though that’s the purpose of syncthing? It’s now more than 24 hours that the last uploaded file hasn’t changed, and also the amount of files on the system (local) hasn’t changed for days (it’s just 1% of the files that have to be uploaded or downloaded, depending on from what machine you want to see it). However, the NAS shows heavy hard disk activity, and there is nothing else going on but Syncthing. I guess this has to do with hashing, but I thought this would be done file by file - when they are downloaded to the machine? Are there ways to help Syncthing if the hardware doesn’t offer much capacity?


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.