deletion of all files by syncthing

There was an error of syncthing (not at Hardware or Software level) which caused a deletion of all data (20 GB)

> 2020-07-28 16:52:26: Error on folder "aegb__P33" (u6sgg-xmuft): folder path missing

The very text of the error shows that the directory was gone and that’s exactly what caused the error in Syncthing. Which means that the directory was already deleted (by something/someone else) when Syncthing complained.



the folder is on the ssd it is directly on the OS/root, so not mounted

there is no OS error that the dir got lost / how should that happen.

Don’t blame something/search for error other than by syncthing. There was nothing happening but syncthing started with out of sync and later this deletion of all files.

The error indicates the entire synced folder is missing. Syncthing isn’t programmed to ever delete that folder, and I’ve never heard of anyone claiming it did before.

On the contrary, Syncthing is designed to react to this situation as an error to prevent other devices from deleting files as a result.

You think so …

But it did it in my case.

  • Why should I lie … no that fact in my case

It did it not only once but twice (only one folder went well [ no full data rewrite])

How is syncthing preventing this? With which option?

  • It wasn’t doing so in my case

What is the reason for this and how to prevent it really/ like in reality.

It seems something special is happening in your case. If you have steps to reproduce it I’m all ears.

ha ha

reproduce deleted data

Is there no help from your side?

How to analyse syncthing for errors? How to protect against those events?

it appears to me that the forum is full of special cases?!

syncthing lost the connection (even though the nodes are connected via lan) BUT nothing else.

like State diff

AND so on and on

You’re asking for help with preventing something Syncthing is programmed to never do, and that in hundreds of thousands of use cases I’ve so far not heard anyone else say it does. I don’t know what to tell you other than that the odds are overwhelmingly in favour of Syncthing not doing this – but if this has happened to you repeatedly, please explain what you did and perhaps we can understand what happened. That’s a “reproducer” for a bug – how to make it happen again.


(To me it appears like you have programmed something that is not controllable? all posts I read was blaming something but not syncthing for data deletion, diffs in state etc. ) Is there no help from this community?

Perhaps we can try to figure out why syncthing did this error (which was not caused by something else the syncthing)

What and how to analyse syncthing for this error?

What options to consider in syncthing to control it?

There are no options to control this behavior because this behavior does not exist in the Syncthing code.

We can analyse this error if you explain the steps leading up to it happening.

How can I tell you about steps when there where nothing. No change, no stept.

What do you want more for reproduce the scenario.

version 1.6.1


Syncthing was setup and worked the day before. Next day it deleted everything on both nodes.

  • No error on the node
  • no lan error
  • ONLY syncthing had issues with itself and delete everything

Yeah I dunno man. You say Syncthing had issues and deleted everything, so I guess you have logs of this that you haven’t shown? Otherwise I have no idea.


Not I’m saying that. I proofed it already, right?

Also I told you that the OS/ network did not show errors.

-> So it would be on syncthing to evaluate what it did and why. That is what I tried to ask. I really thought there would be a community that helps each other …

But in this post like in other the syncthing people are not helpful and do not try to analyse issues of their software (looks like you a afraid of your mistakes)

by the way: " nekr0z Evgeny Kuznetsov Contributor"

He (representing syncthing) wrote: “Which means that the directory was already deleted”

  • He never was interested to get to know about the issue of syncthing
  • He proposed wrong facts (looks like he is not working in Linux)

like I wrote before:

“exactly what caused the error in Syncthing” –> He is writing “exactly without to tell what approximately he means/what could happen to syncthing”

–> the folder was never ever unavailable nor files deleted. It directly in the OS/root. No errors in the OS log

You don’t care about facts, do you?

Why don’t you help to analyse syncthing to figure out about the error.

Show you proficiency and save you blaming and solve the software issues, please. If this issue is quite hard for you, please try to tell me how to analyse syncthing to figure out about the error!

(Proof me to be wrong and solve the easiest question / issue ever -> like Global State is smaller than Local state - diff )

If even that is an “unsolvable” issue of syncthing, please start helping me !

There is nothing to analyze here.

I am 110% sure syncthing did not cause this.

If it did, we would have atleast seen a case like this before over the 7 years or working on it. I have never ever seen anyone report what you are reporting in my 7 years of working on syncthing, and it’s because it never happened, because syncthing is not programmed to do what you what you are accusing it did.

The error message you are presenting as evidence is just syncthing saying the folder is gone. It’s a single line that is not evidence in any way, as it’s saying the folder has gone missing, after the fact it gone missing.

You can keep screaming that you know syncthing did this, keep throwing a fit that nobody is helping you, and playing some sort of morale card about community not being helpful, but I am not sure we sort of help you are after.

As I said, syncthing didn’t do this, so we can’t help you with something it didn’t do.


Just to make it clear why I am not further investigating your issues (@igel), at least not until I see a huge change in attitude:

You are insinuating that I am either imagining spending lots of time (hours a day) on supporting Syncthing users and tracking down bugs or am so bad at it, that it is no help at all (not I exclusively obviously, lots of other community members do as well).

Finally you are judging what is trivial. Let me tell you, it’s not trivial. If you don’t believe me, feel free to show me how trivial it is by fixing it or reimplementing a solution for the trivial problem Syncthing is solving (or not solving, according to you).

All of this I can ignore, I am used to preposterous and self-absorbed people, and it’s a good skill to be able to deal with that. However what makes it entirely a waste of time to interact with you is that you ignore the infos and questions posed to you. You don’t need to agree with it, but the minimum required is to acknowledge it, even with a simple “I do not agree with X”. One example: In the trivial state issue you linked I asked you for the folder type and you responded with “what context do you need?” - answer the questions or nobody can help you.

1 Like

I’d just like to counter some of the posts in this thread by voicing my huge appreciation for the selfless work that this community puts out there.

It’s no small exaggeration to say that this tool has changed the way we live and work.


I think we’re done here. We do generally try to be helpful, but it requires some quid pro quo and insults are not that.