Deleted folder in syncthing-fork, expected prompt to re-add

Hi. I moved a folder in the filesystem on my Android phone. As expected, the Android syncthing-fork wrapper complained about bad filesystem marker. I saw that the wrapper GUI wouldn’t let me choose the new folder location while keeping the same folder settings, which is fair enough.

I deleted the folder in the Android syncthing-fork wrapper GUI, expecting that I would receive a notification or a popup when the other node requested to share the folder, at which point I could point it to the new filesystem folder and configure as appropriate.

Instead, I did not receive any such notification. If I open the syncthing web GUI on the phone, I do see the remote node wishing to share the folder with the phone, and of course I could use that to add the folder, but I thought the Android wrapper GUI should also allow that.

Am I wrong and this isn’t a feature of the wrapper GUI?

By the way, I couldn’t find any particular documentation about the wrapper with regards to what it can/can’t do.

Many thanks in advance.


Thanks for your detailed report. I’ll check the popup notification one again during next dev session. It should come up on android notifications but may be a little bit delayed (I recall ~ 20…40 secs later after the web ui would display it due to the event sink reader and “power saving” sleeps in cycles). Maybe restarting the app from the drawer menu helps?

What the wrapper can do is constantly extended, but yet there isn’t a feature list on the wiki.

Kind regards Catfriend1

1 Like

Thanks. I should have said that I tried restarting Syncthing from the drawer with no difference.

There is a difference how the two UIs display the notifications. Both UIs used to check the last 1000 events in the UI queue and see if it can find any notifications, that clearly sucked because if more than 1k events happened since, the request to share notifications would roll off. Syncthing now has persistent notifications which are stored in the config and the web ui uses that, and android probably does not.


I have also restarted my phone and still no (Android) notification. Notification is still showing in the web UI.

Ok thanks for the pointer, so I’ll change code to the persistent notification part of config.xml :slight_smile:

1 Like


I’ve had a look at the logcat of the EventProcessor. It only seems to emit “ConfigSaved” event but no longer FolderRejected?! Can anyone from upstream please confirm if this is intended behaviour? So I would have to catch the first “ConfigSaved” on startup and lurk at pendingFolders to get the notification firing, correct?

Kind regards Catfriend1

It’s still emitted:

Ok then I’ll doublecheck and see what’s the best way to solve it. I would prefer using the ConfigRouter, but as that is not on official code solving it by RestApi lookup is better.

Indeed - The event is still emitted, I’ve made a quick tutorial video but had a long time to wait for a connection between phone and computer until I got the notification. Thought it was because of ( Syncthing devices are suddenly disconnected, context deadline exceeded and i/o timeout ) ?! So it worked, that’s the message.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.