Default ignores won't save (#7428)

v1.19.0-rc1 (Linux)

After reopen, the ignore list is empty. Same after restart ST. Although, the new feature works as expected even after restart. If the default settings dialog was able to read the config, it would be perfect (allow changes instead of typing in the previous list again for edit). Thanks Devs… Still great soft

Same here, I can not store any content.

As feature request: Is also possible to have device ignores, it means a ignore setting is working regarding the whole device?

Very good is the possibility of #include .stglobalignore as entrance in the .stignore so I can exchange folder wide. If I have the same content in all .stglobalignore it makes sence to have a device wide option.

1 Like

Default patterns are in fact saved (i.e. they are added to config.xml), but the GUI fails to display them. They are still applied when adding a new folder though.

1 Like

What is the parameter in the config.xml?

Fix: gui: Fix loading default ignores (ref #7530) by imsodin · Pull Request #8135 · syncthing/syncthing · GitHub
Will result in a new RC soonish.