Debian Distri | Syncthing v1.0.0

It seems, that in the Debian distribution the current Syncthing v1.0.0-ds1-1+b11_amd64.deb is not the orginal v1.0.0, or is really the same?

We have no idea what debian ships.

We recommend using our distribution channels.

We’ve seen them use incompatible compilers and shipping broken versions.

I try at first the software package of the distribution. After I see the version v1.0.0 I use the follow way, is on your download page described:

## Debian / Ubuntu Packages

You can choose between the “stable” (latest release) or “candidate” (earlier release candidate) tracks. The stable channel is updated usually every first Tuesday of the month.

# Add the release PGP keys:
curl -s | sudo apt-key add -

# Add the "stable" channel to your APT sources:
echo "deb syncthing stable" | sudo tee /etc/apt/sources.list.d/syncthing.list

# Update and install syncthing:
sudo apt-get update
sudo apt-get install syncthing

but with the same result, also with this way I got the v1.0.0 as above.

BTW the command curl -s | sudo apt-key add - doesnt work on Debian.

If I use the same way with Linux Mint (Ubuntu), I got the correct v1.8.0

Its probably something todo with how debian sorts versions. You might need to purge the old installation before hand, or tell apt to use a specific source.

Or, you know, show what “doesn’t work” and you may get tips or we can fix whatever is bad.

1 Like

Hello, I had the same issue, after checking the versions on debian today. If i use

apt install syncthing

i get the package from the debian repos (version 1.0.0). looks like you have to specify the repo correctly.

This commands will work.

apt purge syncthing
apt install -t syncthing syncthing

syncthing -version
syncthing v1.8.0 “Fermium Flea” (go1.14.7 linux-amd64) 2020-08-07 06:09:12 UTC

Thanks that works with sudo … : v1.8.0 :+1:

Can you please post the output of apt policy syncthing.


root@LinuxDebian-VM:/# apt policy syncthing
  Installiert:           1.8.0
  Installationskandidat: 1.8.0
 *** 1.8.0 500
        500 syncthing/stable amd64 Packages
        100 /var/lib/dpkg/status
     1.7.1 500
        500 syncthing/stable amd64 Packages
     1.7.0 500
        500 syncthing/stable amd64 Packages
     1.0.0~ds1-1+b11 500
        500 buster/main amd64 Packages

With Linux Mint, was no problem with installation, but the result to compare:

root@LinuxMint-VM:~# apt policy syncthing
  Installiert:           1.9.0~rc.4
  Installationskandidat: 1.9.0~rc.4
 *** 1.9.0~rc.4 500
        500 syncthing/candidate amd64 Packages
        100 /var/lib/dpkg/status
     1.9.0~rc.3 500
        500 syncthing/candidate amd64 Packages
     1.9.0~rc.2 500
        500 syncthing/candidate amd64 Packages
     1.9.0~rc.1 500
        500 syncthing/candidate amd64 Packages
     1.8.0 500
        500 syncthing/candidate amd64 Packages
     1.8.0~rc.4 500
        500 syncthing/candidate amd64 Packages
     1.8.0~rc.3 500
        500 syncthing/candidate amd64 Packages
     1.8.0~rc.2 500
        500 syncthing/candidate amd64 Packages
     1.8.0~rc.1 500
        500 syncthing/candidate amd64 Packages
     1.7.1 500
        500 syncthing/candidate amd64 Packages
     1.7.0 500
        500 syncthing/candidate amd64 Packages
     1.1.4~ds1-4ubuntu1 500
        500 focal/universe amd64 Packages

In this distribution I use directly the way from your download page.

I don’t see why there would be a problem with either of these, really.

I find it strange that distributions have such old versions.

Syncthing was not offered in the GUI software packages in Linux Mint. But in Debian, and that led me to install it. It was not quite clear to me that the v1.0.0 of the distribution corresponds to the v1.0.0 of your version. If so, it is out of date and there might be problems if other devices have the current v1.8.0 or v1.9.0-rc.4.

Since one distribution has v1.8.0 and the other v1.9.0-rc.4, the problem has now been solved. So far, these now working perfectly.

You can assume that pretty much all software in a released distribution like Debian is a couple of years old, you may just not have noticed because you didn’t track them as carefully as you may have done with Syncthing. This is how distributions work. They test a certain set of package versions, then lock that in and ship it for the distribution lifetime (plus security updates etc).

It would be astonishing if their version 1.0.0 wasn’t our 1.0.0 (plus/minus the changes they’ve made).

This is also the reason why exists.

For your Debian specifically, see the life cycle dates. It was frozen in the beginning of 2019, when 1.0.0 was the latest version.

1 Like

Actually, there might be a weird catch here with preference values and target systems:

   990 <= P < 1000
       causes a version to be installed even if it does not come from the
       target release, unless the installed version is more recent

   500 <= P < 990
       causes a version to be installed unless there is a version
       available belonging to the target release or the installed version
       is more recent

On debian testing, there’s no target set in config. I assume that’s also the case on mint/ubuntu. Where on debian stable, there likely is a target. You can check by running: apt-config dump apt::default-release

We should probably add another instruction for the apt installation, something like

printf "Package: *\nPin: origin\nPin-Priority: 990\n" | sudo tee /etc/apt/preferences.d/syncthing
1 Like

TIL. I don’t think I’ve ever run Debian stable. :slight_smile:

Also, looking at the update criteria for Debian releases, if we made sure we had a significant security problem about every six months maybe we could get recent versions in there with regularity.

1 Like

My homeserver is running debian oldstable :smiley:

Btw that means I can check my hypothesis above, and it’s partially wrong: apt::default-release is not set. However looking at my preferences I had this problem myself years ago and forgot: I have those preferences.d/syncthing files pinning to 990 in place :slight_smile:

You get a minimal patch at best. However due to obvious problems (dependency management/static linking) I believe there’s a few problems with debian’s security processes and go programs in general. As I am a happy debian user I started to look into that a bit, and it’s… difficult.

1 Like

It means “2019-07-06: Initial release: 10.0”, currently I have the update 10.5 installed “2020-08-01: Updated (10.5)” but without the update among others of Syncthing. :rage:

Debian’s dot releases do not include newer program versions. They only include security fixes (which you already get subscribing to the security repos, which you should and do by default) and “important” bugs. What the latter means isn’t entirely clear to me, but definitely not including newer Syncthing versions :slight_smile:


I see your oldstable and raise to lenny

jb@pbns2:~$ cat /etc/debian_version

(s’not, technically, my box… or it wouldn’t be in this situation :D)

1 Like

Seems like you would expect the latest upstream versions of software provided by the distribution.

Luckily there are also distributions unlike Debian which try to ship the latest and greatest version of every package as soon as possible, e.g. rolling release distributions.

1 Like